aboutsummaryrefslogtreecommitdiffstats
path: root/main/mesa/add-glx-use-tls.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/mesa/add-glx-use-tls.patch')
-rw-r--r--main/mesa/add-glx-use-tls.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/main/mesa/add-glx-use-tls.patch b/main/mesa/add-glx-use-tls.patch
new file mode 100644
index 0000000000..dff55b58e4
--- /dev/null
+++ b/main/mesa/add-glx-use-tls.patch
@@ -0,0 +1,47 @@
+From f895a39b7437381a86383dd97250aa2cc7393bff Mon Sep 17 00:00:00 2001
+From: maxice8 <thinkabit.ukim@gmail.com>
+Date: Thu, 9 Aug 2018 18:37:30 -0300
+Subject: [PATCH] meson: add glx-use-tls option.
+
+---
+ meson.build | 6 +++++-
+ meson_options.txt | 6 ++++++
+ 2 files changed, 11 insertions(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 5dbb786..1ab3092 100644
+--- a/meson.build
++++ b/meson.build
+@@ -340,7 +340,11 @@ if with_egl and not (with_platform_drm or with_platform_surfaceless)
+ endif
+ endif
+
+-pre_args += '-DGLX_USE_TLS'
++with_glx_use_tls = get_option('glx-use-tls')
++if with_glx_use_tls
++ pre_args += '-DGLX_USE_TLS'
++endif
++
+ if with_glx != 'disabled'
+ if not (with_platform_x11 and with_any_opengl)
+ if with_glx == 'auto'
+diff --git a/meson_options.txt b/meson_options.txt
+index 496fe38..12981dd 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -195,6 +195,12 @@ option(
+ choices : ['auto', 'disabled', 'dri', 'xlib', 'gallium-xlib'],
+ description : 'Build support for GLX platform'
+ )
++option(
++ 'glx-use-tls',
++ type : 'boolean',
++ value : true,
++ description : 'Build support for initial-exec TLS model on GLX platform'
++)
+ option(
+ 'egl',
+ type : 'combo',
+--
+2.18.0
+