aboutsummaryrefslogtreecommitdiffstats
path: root/main/mozjs60
diff options
context:
space:
mode:
Diffstat (limited to 'main/mozjs60')
-rw-r--r--main/mozjs60/APKBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/main/mozjs60/APKBUILD b/main/mozjs60/APKBUILD
index 2aba00eb12..3080278595 100644
--- a/main/mozjs60/APKBUILD
+++ b/main/mozjs60/APKBUILD
@@ -2,10 +2,10 @@
pkgname=mozjs60
pkgver=60.6.1
_majver=${pkgver%%.*}
-pkgrel=0
+pkgrel=1
pkgdesc="standalone mozilla javascript engine"
url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey/Releases/60"
-arch="all !armhf !armv7 !s390x"
+arch="all !s390x"
license="MPL-2.0"
depends_dev="icu-dev nspr-dev libffi-dev readline-dev"
makedepends="$depends_dev zlib-dev python2 perl sed autoconf2.13 linux-headers"
@@ -21,9 +21,17 @@ _builddir="$builddir/js/src"
build() {
cd "$_builddir"
+ export LDFLAGS="$LDFLAGS -Wl,-z,stack-size=1048576"
+
# avoid complains about autoconf
touch configure
+ # Fix broken ARM_ARCH check which doesn't work with newer GCCs it seems.
+ if [ "$CTARGET" = "armv*" ]; then
+ ARM_ARCH=$(echo ${CTARGET#*armv} | sed "s|-.*||")
+ sed -i "s|ARM_ARCH=.*|ARM_ARCH=$ARM_ARCH|" "$builddir"/build/autoconf/arch.m4
+ fi
+
export SHELL=/bin/ash
PYTHON=/usr/bin/python2 ./configure --prefix=/usr \
--with-system-icu \