aboutsummaryrefslogtreecommitdiffstats
path: root/main/nghttp2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/nghttp2/APKBUILD')
-rw-r--r--main/nghttp2/APKBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/main/nghttp2/APKBUILD b/main/nghttp2/APKBUILD
index 0a0ccf0125..410003485a 100644
--- a/main/nghttp2/APKBUILD
+++ b/main/nghttp2/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=nghttp2
-pkgver=1.32.0
+pkgver=1.33.0
pkgrel=0
pkgdesc="Experimental HTTP/2 client, server and proxy"
url="https://nghttp2.org"
@@ -9,12 +9,19 @@ arch="all"
license="MIT"
makedepends="libev-dev libressl-dev zlib-dev c-ares-dev autoconf automake libtool"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
-source="https://github.com/tatsuhiro-t/$pkgname/releases/download/v$pkgver/nghttp2-$pkgver.tar.xz"
+source="https://github.com/tatsuhiro-t/$pkgname/releases/download/v$pkgver/nghttp2-$pkgver.tar.xz
+remove-mruby-tests.patch"
builddir="$srcdir"/$pkgname-$pkgver
check() {
cd "$builddir"
make check
+ # integration tests require go, which is only available
+ # in community at the moment of writing. Disabling until
+ # go is moved into main
+# cd "integration-tests"
+# make itprep
+# make it
}
build() {
@@ -43,4 +50,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="ec7e417fbc5497861d2b6dde5145da1640b36441882824e85940e5ca6ac52ec444aa7123846960f7211dd96462eab421d39f9cc49454f3f52e0dcdb36402044e nghttp2-1.32.0.tar.xz"
+sha512sums="eeb0bf64fea115444c685c8a01c1017ce96be18adf88ffcdecad067de7012ca61c6b2b6a627b18e2572bba7bd77ec56a3ca4b1109f7a4b21220e8e28687b5b74 nghttp2-1.33.0.tar.xz
+d3f6a66ad6522babb5ad2b3721d52c1c2af88e57ed2895cf87037da1032ca42dcb95dacc23ea277b9507b4116cec117b5c9a3313759dc56b48199b687b74dd9a remove-mruby-tests.patch"