aboutsummaryrefslogtreecommitdiffstats
path: root/main/nginx/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/nginx/APKBUILD')
-rw-r--r--main/nginx/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/main/nginx/APKBUILD b/main/nginx/APKBUILD
index 3668897e55..578b1f12f2 100644
--- a/main/nginx/APKBUILD
+++ b/main/nginx/APKBUILD
@@ -4,11 +4,12 @@
pkgname=nginx
pkgver=1.4.3
-pkgrel=0
+pkgrel=1
pkgdesc="lightweight HTTP and reverse proxy server"
url="http://www.nginx.org"
arch="all"
license="Custom"
+install="$pkgname.pre-install $pkgname.pre-upgrade"
makedepends="pcre-dev openssl-dev zlib-dev"
source="http://nginx.org/download/$pkgname-$pkgver.tar.gz
nginx.initd
@@ -36,8 +37,8 @@ build() {
--http-client-body-temp-path=/tmp/$pkgname/client-body \
--http-proxy-temp-path=/tmp/$pkgname/proxy \
--http-fastcgi-temp-path=/tmp/$pkgname/fastcgi \
- --user=http \
- --group=http \
+ --user=nginx \
+ --group=nginx \
--with-ipv6 \
--with-pcre-jit \
--with-http_ssl_module \