aboutsummaryrefslogtreecommitdiffstats
path: root/main/nodejs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/nodejs/APKBUILD')
-rw-r--r--main/nodejs/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/main/nodejs/APKBUILD b/main/nodejs/APKBUILD
index e943d6e7da..29c8ebed03 100644
--- a/main/nodejs/APKBUILD
+++ b/main/nodejs/APKBUILD
@@ -1,4 +1,3 @@
-# Contributor: Jose-Luis Rivas <me@ghostbar.co>
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: Eivind Uggedal <eivind@uggedal.com>
pkgname=nodejs
@@ -26,9 +25,11 @@ prepare() {
build() {
cd "$_builddir"
+ [ "$CARCH" = "armhf" ] && local _FPU="--with-arm-fpu=vfpv3-d16"
./configure --prefix=/usr \
--shared-zlib \
--shared-libuv \
+ $_FPU \
--shared-openssl || return 1
make || return 1
}