aboutsummaryrefslogtreecommitdiffstats
path: root/main/ntfs-3g/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/ntfs-3g/APKBUILD')
-rw-r--r--main/ntfs-3g/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/main/ntfs-3g/APKBUILD b/main/ntfs-3g/APKBUILD
new file mode 100644
index 0000000000..29c32668fb
--- /dev/null
+++ b/main/ntfs-3g/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=ntfs-3g
+pkgver=2011.4.12
+pkgrel=1
+pkgdesc="A userspace ntfs driver with write support"
+url="http://www.tuxera.com/community/ntfs-3g-download/"
+arch="all"
+license="GPL"
+depends=
+makedepends="attr-dev"
+subpackages="$pkgname-doc $pkgname-dev"
+source="http://tuxera.com/opensource/ntfs-3g_ntfsprogs-$pkgver.tgz"
+
+_builddir="$srcdir"/ntfs-3g_ntfsprogs-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" LDCONFIG=: install || return 1
+ rm "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="9c4ce318373b15332239a77a9d2a39fe ntfs-3g_ntfsprogs-2011.4.12.tgz"