aboutsummaryrefslogtreecommitdiffstats
path: root/main/omxplayer/fix-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/omxplayer/fix-makefile.patch')
-rw-r--r--main/omxplayer/fix-makefile.patch9
1 files changed, 6 insertions, 3 deletions
diff --git a/main/omxplayer/fix-makefile.patch b/main/omxplayer/fix-makefile.patch
index 23a206d71f..76f11870ce 100644
--- a/main/omxplayer/fix-makefile.patch
+++ b/main/omxplayer/fix-makefile.patch
@@ -1,16 +1,19 @@
--- omxplayer-2ee17b22a6149a043a2e402580504f282c615373.orig/Makefile
+++ omxplayer-2ee17b22a6149a043a2e402580504f282c615373/Makefile
-@@ -3,7 +3,10 @@
+@@ -3,9 +3,12 @@
LDFLAGS=-L$(SDKSTAGE)/opt/vc/lib/
LDFLAGS+=-L./ -Lffmpeg_compiled/usr/local/lib/ -lc -lbrcmGLESv2 -lbrcmEGL -lbcm_host -lopenmaxil -lfreetype -lz -lasound
+LDFLAGS+=-L./ -Lffmpeg_compiled/usr/local/lib/
+LIBS+=-lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz -lasound
-+
- INCLUDES+=-I./ -Ilinux -Iffmpeg_compiled/usr/local/include/ -I /usr/include/dbus-1.0 -I /usr/lib/arm-linux-gnueabihf/dbus-1.0/include -I/usr/include/freetype2 -isystem$(SDKSTAGE)/opt/vc/include -isystem$(SDKSTAGE)/opt/vc/include/interface/vcos/pthreads
+-INCLUDES+=-I./ -Ilinux -Iffmpeg_compiled/usr/local/include/ -I /usr/include/dbus-1.0 -I /usr/lib/arm-linux-gnueabihf/dbus-1.0/include -I/usr/include/freetype2 -isystem$(SDKSTAGE)/opt/vc/include -isystem$(SDKSTAGE)/opt/vc/include/interface/vcos/pthreads
++INCLUDES+=-I./ -Ilinux $(shell pkg-config --cflags dbus-1 freetype2) -isystem$(SDKSTAGE)/opt/vc/include -isystem$(SDKSTAGE)/opt/vc/include/interface/vcos/pthreads
++
DIST ?= omxplayer-dist
+ STRIP ?= strip
+
@@ -50,10 +53,10 @@
omxplayer.o: help.h keys.h