aboutsummaryrefslogtreecommitdiffstats
path: root/main/open-vm-tools/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/open-vm-tools/APKBUILD')
-rw-r--r--main/open-vm-tools/APKBUILD91
1 files changed, 91 insertions, 0 deletions
diff --git a/main/open-vm-tools/APKBUILD b/main/open-vm-tools/APKBUILD
new file mode 100644
index 0000000000..d6e04a0656
--- /dev/null
+++ b/main/open-vm-tools/APKBUILD
@@ -0,0 +1,91 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=open-vm-tools
+pkgver=2011.05.27
+_pkgsubver=420096
+pkgrel=0
+pkgdesc="The Open Virtual Machine Tools are the open source implementation of VMware Tools."
+url="http://open-vm-tools.sourceforge.net/"
+arch="all"
+license="LGPL"
+subpackages="$pkgname-gtk $pkgname-dev"
+install="$pkgname.pre-install"
+makedepends="procps-dev libdnet-dev icu-dev glib-dev pkgconfig bash
+ libtirpc-dev rpcgen icu-dev automake autoconf
+ gtk+-dev libxext-dev libxinerama-dev libxtst-dev gtkmm-dev
+ libnotify-dev libxrandr-dev
+ "
+source="http://downloads.sourceforge.net/open-vm-tools/open-vm-tools-$pkgver-$_pkgsubver.tar.gz
+ getloadavg-uclibc.patch
+ codeset-uclibc.patch
+ ecvt.patch
+ iconv-uclibc.patch
+ libm.patch
+ open-vm-tools.initd
+ procmgrposix.patch
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver-$_pkgsubver
+
+prepare() {
+ cd "$_builddir"
+ for i in "$srcdir"/*.patch; do
+ [ -r "$i" ] || continue
+ patch -p1 -i "$i" || return 1
+ done
+
+ sed -i -e 's/__unused1/st_atim.tv_nsec/g' \
+ -e 's/__unused2/st_mtim.tv_nsec/g' \
+ -e 's/__unused3/st_ctim.tv_nsec/g' \
+ lib/file/filePosix.c lib/hgfsServer/hgfsServerLinux.c \
+ || return 1
+
+ # workaround automake-1.10 issue
+ # http://ramblingfoo.blogspot.com/2007/07/required-file-configrpath-not-found.html
+ touch config/config.rpath
+ aclocal -I m4 && autoconf && automake
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --disable-unity \
+ --with-dnet \
+ --with-icu \
+ --with-procps \
+ --with-x \
+ --without-kernel-modules \
+ --without-pam \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR=$pkgdir || return 1
+ install -Dm755 "$srcdir"/open-vm-tools.initd \
+ "$pkgdir"/etc/init.d/open-vm-tools
+ find "$pkgdir" -name '*.la' -delete
+}
+
+gtk() {
+ pkgdesc="Xorg apps and plugins for open-vm-tools"
+ mkdir -p "$subpkgdir"/usr/bin \
+ "$subpkgdir"/usr/lib/open-vm-tools/plugins \
+ "$subpkgdir"/etc/
+ mv "$pkgdir"/usr/bin/vmware-toolbox \
+ "$pkgdir"/usr/bin/vmware-user-suid-wrapper \
+ "$subpkgdir"/usr/bin/
+ mv "$pkgdir"/etc/xdg "$subpkgdir"/etc/
+ mv "$pkgdir"/usr/lib/open-vm-tools/plugins/vmusr \
+ "$subpkgdir"/usr/lib/open-vm-tools/plugins/
+}
+
+md5sums="3e43d4857d412d02115e69db193830b5 open-vm-tools-2011.05.27-420096.tar.gz
+49e2e394d0b567fa71fcd295e96bc1c8 getloadavg-uclibc.patch
+82840b6bed002284b9bd2358707ee826 codeset-uclibc.patch
+840e4d6ff3f53fc22bdedf4d64aabc91 ecvt.patch
+89c7449323ddac4666b73a8467baf95a iconv-uclibc.patch
+7d02fc25aba5c248f3d98dac238f175b libm.patch
+c96644aa42d611fae853a3a2095efc47 open-vm-tools.initd
+7b833102a56009bdfc2fef2fb9ffa297 procmgrposix.patch"