aboutsummaryrefslogtreecommitdiffstats
path: root/main/openjdk7
diff options
context:
space:
mode:
Diffstat (limited to 'main/openjdk7')
-rw-r--r--main/openjdk7/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/main/openjdk7/APKBUILD b/main/openjdk7/APKBUILD
index b286c14b46..d257ab6ce9 100644
--- a/main/openjdk7/APKBUILD
+++ b/main/openjdk7/APKBUILD
@@ -28,7 +28,10 @@ ANT_VER=1.9.2
case $CARCH in
x86) _jarch=i386;;
x86_64) _jarch=amd64;;
-arm*) _jarch=arm;;
+arm*) _jarch=arm
+ # openjdk has quite a bit of arm assembly producing textrels
+ # and it's non trivial to fix. allow it that for now.
+ options="$options textrels";;
esac
INSTALL_BASE=/usr/lib/jvm/java-1.7-openjdk