aboutsummaryrefslogtreecommitdiffstats
path: root/main/openobex/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/openobex/APKBUILD')
-rw-r--r--main/openobex/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/main/openobex/APKBUILD b/main/openobex/APKBUILD
new file mode 100644
index 0000000000..caaecb85e7
--- /dev/null
+++ b/main/openobex/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=openobex
+pkgver=1.5
+pkgrel=3
+pkgdesc="Implementation of the OBject EXchange (OBEX) protocol"
+url="http://dev.zuckschwerdt.org/openobex/"
+arch="all"
+license="GPL LGPL"
+depends=
+depends_dev="libusb-compat-dev"
+makedepends="bluez-dev libusb-compat-dev"
+subpackages="$pkgname-dev libopenobex"
+source="http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr \
+ --enable-apps \
+ --enable-irda \
+ --enable-bluetooth \
+ --enable-usb \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+libopenobex() {
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libopenobex.so.* "$subpkgdir"/usr/lib/
+}
+
+md5sums="fce1b82eafb74bde54fe117372393ba8 openobex-1.5.tar.bz2"