aboutsummaryrefslogtreecommitdiffstats
path: root/main/openssl/0005-fix-parallel-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/openssl/0005-fix-parallel-build.patch')
-rw-r--r--main/openssl/0005-fix-parallel-build.patch101
1 files changed, 48 insertions, 53 deletions
diff --git a/main/openssl/0005-fix-parallel-build.patch b/main/openssl/0005-fix-parallel-build.patch
index f33db3517e..24bc5d643e 100644
--- a/main/openssl/0005-fix-parallel-build.patch
+++ b/main/openssl/0005-fix-parallel-build.patch
@@ -1,21 +1,7 @@
-From ee8d4adddccd275f30cf3f489478f2fbc94dadbb Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
-Date: Thu, 5 Feb 2015 08:53:54 +0200
-Subject: [PATCH] fix parallel build
-
----
- Makefile.org | 42 +++++++++++++++++---------------
- Makefile.shared | 2 ++
- crypto/Makefile | 10 ++++----
- engines/Makefile | 6 ++---
- test/Makefile | 74 ++++++++++++++++++++++++++++----------------------------
- 5 files changed, 69 insertions(+), 65 deletions(-)
-
-diff --git a/Makefile.org b/Makefile.org
-index 035fa83..5dab54e 100644
---- a/Makefile.org
-+++ b/Makefile.org
-@@ -274,17 +274,17 @@ build_all: build_libs build_apps build_tests build_tools
+diff -ru openssl-1.0.2a.orig/Makefile.org openssl-1.0.2a/Makefile.org
+--- openssl-1.0.2a.orig/Makefile.org 2015-03-19 13:30:36.000000000 +0000
++++ openssl-1.0.2a/Makefile.org 2015-03-19 14:53:31.246908039 +0000
+@@ -274,17 +274,17 @@
build_libs: build_crypto build_ssl build_engines
build_crypto:
@@ -44,7 +30,7 @@ index 035fa83..5dab54e 100644
all_testapps: build_libs build_testapps
build_testapps:
-@@ -536,9 +536,9 @@ dist:
+@@ -536,9 +536,9 @@
dist_pem_h:
(cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
@@ -56,7 +42,7 @@ index 035fa83..5dab54e 100644
@$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
$(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR) \
$(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines \
-@@ -547,12 +547,19 @@ install_sw:
+@@ -547,12 +547,19 @@
$(INSTALL_PREFIX)$(OPENSSLDIR)/misc \
$(INSTALL_PREFIX)$(OPENSSLDIR)/certs \
$(INSTALL_PREFIX)$(OPENSSLDIR)/private
@@ -77,7 +63,7 @@ index 035fa83..5dab54e 100644
@set -e; liblist="$(LIBS)"; for i in $$liblist ;\
do \
if [ -f "$$i" ]; then \
-@@ -636,12 +643,7 @@ install_html_docs:
+@@ -636,12 +643,7 @@
done; \
done
@@ -91,11 +77,10 @@ index 035fa83..5dab54e 100644
@pod2man="`cd ./util; ./pod2mantest $(PERL)`"; \
here="`pwd`"; \
filecase=; \
-diff --git a/Makefile.shared b/Makefile.shared
-index e753f44..8d57163 100644
---- a/Makefile.shared
-+++ b/Makefile.shared
-@@ -105,6 +105,7 @@ LINK_SO= \
+diff -ru openssl-1.0.2a.orig/Makefile.shared openssl-1.0.2a/Makefile.shared
+--- openssl-1.0.2a.orig/Makefile.shared 2015-01-20 12:33:36.000000000 +0000
++++ openssl-1.0.2a/Makefile.shared 2015-03-19 14:53:31.246908039 +0000
+@@ -105,6 +105,7 @@
SHAREDFLAGS="$${SHAREDFLAGS:-$(CFLAGS) $(SHARED_LDFLAGS)}"; \
LIBPATH=`for x in $$LIBDEPS; do echo $$x; done | sed -e 's/^ *-L//;t' -e d | uniq`; \
LIBPATH=`echo $$LIBPATH | sed -e 's/ /:/g'`; \
@@ -103,7 +88,7 @@ index e753f44..8d57163 100644
LD_LIBRARY_PATH=$$LIBPATH:$$LD_LIBRARY_PATH \
$${SHAREDCMD} $${SHAREDFLAGS} \
-o $$SHLIB$$SHLIB_SOVER$$SHLIB_SUFFIX \
-@@ -122,6 +123,7 @@ SYMLINK_SO= \
+@@ -122,6 +123,7 @@
done; \
fi; \
if [ -n "$$SHLIB_SOVER" ]; then \
@@ -111,11 +96,10 @@ index e753f44..8d57163 100644
( $(SET_X); rm -f $$SHLIB$$SHLIB_SUFFIX; \
ln -s $$prev $$SHLIB$$SHLIB_SUFFIX ); \
fi; \
-diff --git a/crypto/Makefile b/crypto/Makefile
-index 9a39e93..15828ce 100644
---- a/crypto/Makefile
-+++ b/crypto/Makefile
-@@ -85,11 +85,11 @@ testapps:
+diff -ru openssl-1.0.2a.orig/crypto/Makefile openssl-1.0.2a/crypto/Makefile
+--- openssl-1.0.2a.orig/crypto/Makefile 2015-03-19 13:31:02.000000000 +0000
++++ openssl-1.0.2a/crypto/Makefile 2015-03-19 14:53:31.246908039 +0000
+@@ -85,11 +85,11 @@
@if [ -z "$(THIS)" ]; then $(MAKE) -f $(TOP)/Makefile reflect THIS=$@; fi
subdirs:
@@ -129,7 +113,7 @@ index 9a39e93..15828ce 100644
links:
@$(PERL) $(TOP)/util/mklink.pl ../include/openssl $(EXHEADER)
-@@ -100,7 +100,7 @@ links:
+@@ -100,7 +100,7 @@
# lib: $(LIB): are splitted to avoid end-less loop
lib: $(LIB)
@touch lib
@@ -138,7 +122,7 @@ index 9a39e93..15828ce 100644
$(AR) $(LIB) $(LIBOBJ)
test -z "$(FIPSLIBDIR)" || $(AR) $(LIB) $(FIPSLIBDIR)fipscanister.o
$(RANLIB) $(LIB) || echo Never mind.
-@@ -111,7 +111,7 @@ shared: buildinf.h lib subdirs
+@@ -111,7 +111,7 @@
fi
libs:
@@ -147,7 +131,7 @@ index 9a39e93..15828ce 100644
install:
@[ -n "$(INSTALLTOP)" ] # should be set by top Makefile...
-@@ -120,7 +120,7 @@ install:
+@@ -120,7 +120,7 @@
(cp $$i $(INSTALL_PREFIX)$(INSTALLTOP)/include/openssl/$$i; \
chmod 644 $(INSTALL_PREFIX)$(INSTALLTOP)/include/openssl/$$i ); \
done;
@@ -156,11 +140,10 @@ index 9a39e93..15828ce 100644
lint:
@target=lint; $(RECURSIVE_MAKE)
-diff --git a/engines/Makefile b/engines/Makefile
-index da6c875..d675f5c 100644
---- a/engines/Makefile
-+++ b/engines/Makefile
-@@ -72,7 +72,7 @@ top:
+diff -ru openssl-1.0.2a.orig/engines/Makefile openssl-1.0.2a/engines/Makefile
+--- openssl-1.0.2a.orig/engines/Makefile 2015-03-19 13:31:14.000000000 +0000
++++ openssl-1.0.2a/engines/Makefile 2015-03-19 14:53:31.246908039 +0000
+@@ -72,7 +72,7 @@
all: lib subdirs
@@ -169,7 +152,7 @@ index da6c875..d675f5c 100644
@if [ -n "$(SHARED_LIBS)" ]; then \
set -e; \
for l in $(LIBNAMES); do \
-@@ -89,7 +89,7 @@ lib: $(LIBOBJ)
+@@ -89,7 +89,7 @@
subdirs:
echo $(EDIRS)
@@ -178,7 +161,7 @@ index da6c875..d675f5c 100644
files:
$(PERL) $(TOP)/util/files.pl Makefile >> $(TOP)/MINFO
-@@ -128,7 +128,7 @@ install:
+@@ -128,7 +128,7 @@
mv -f $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/$$pfx$$l$$sfx.new $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines/$$pfx$$l$$sfx ); \
done; \
fi
@@ -187,11 +170,10 @@ index da6c875..d675f5c 100644
tags:
ctags $(SRC)
-diff --git a/test/Makefile b/test/Makefile
-index bc4a920..58822f8 100644
---- a/test/Makefile
-+++ b/test/Makefile
-@@ -132,7 +132,7 @@ install:
+diff -ru openssl-1.0.2a.orig/test/Makefile openssl-1.0.2a/test/Makefile
+--- openssl-1.0.2a.orig/test/Makefile 2015-03-19 13:31:16.000000000 +0000
++++ openssl-1.0.2a/test/Makefile 2015-03-19 14:55:44.146017128 +0000
+@@ -133,7 +133,7 @@
tags:
ctags $(SRC)
@@ -200,7 +182,7 @@ index bc4a920..58822f8 100644
apps:
@(cd ..; $(MAKE) DIRS=apps all)
-@@ -398,109 +398,109 @@ BUILD_CMD_STATIC=shlib_target=; \
+@@ -402,121 +402,121 @@
link_app.$${shlib_target}
$(RSATEST)$(EXE_EXT): $(RSATEST).o $(DLIBCRYPTO)
@@ -319,6 +301,10 @@ index bc4a920..58822f8 100644
- @target=$(EVPTEST); $(BUILD_CMD)
+ +@target=$(EVPTEST); $(BUILD_CMD)
+ $(EVPEXTRATEST)$(EXE_EXT): $(EVPEXTRATEST).o $(DLIBCRYPTO)
+- @target=$(EVPEXTRATEST); $(BUILD_CMD)
++ +@target=$(EVPEXTRATEST); $(BUILD_CMD)
+
$(ECDSATEST)$(EXE_EXT): $(ECDSATEST).o $(DLIBCRYPTO)
- @target=$(ECDSATEST); $(BUILD_CMD)
+ +@target=$(ECDSATEST); $(BUILD_CMD)
@@ -344,8 +330,20 @@ index bc4a920..58822f8 100644
+ +@target=$(SRPTEST); $(BUILD_CMD)
$(V3NAMETEST)$(EXE_EXT): $(V3NAMETEST).o $(DLIBCRYPTO)
- @target=$(V3NAMETEST); $(BUILD_CMD)
-@@ -522,7 +522,7 @@ $(CONSTTIMETEST)$(EXE_EXT): $(CONSTTIMETEST).o
+- @target=$(V3NAMETEST); $(BUILD_CMD)
++ +@target=$(V3NAMETEST); $(BUILD_CMD)
+
+ $(HEARTBEATTEST)$(EXE_EXT): $(HEARTBEATTEST).o $(DLIBCRYPTO)
+- @target=$(HEARTBEATTEST); $(BUILD_CMD_STATIC)
++ +@target=$(HEARTBEATTEST); $(BUILD_CMD_STATIC)
+
+ $(CONSTTIMETEST)$(EXE_EXT): $(CONSTTIMETEST).o
+- @target=$(CONSTTIMETEST) $(BUILD_CMD)
++ +@target=$(CONSTTIMETEST) $(BUILD_CMD)
+
+ #$(AESTEST).o: $(AESTEST).c
+ # $(CC) -c $(CFLAGS) -DINTERMEDIATE_VALUE_KAT -DTRACE_KAT_MCT $(AESTEST).c
+@@ -529,7 +529,7 @@
# fi
dummytest$(EXE_EXT): dummytest.o $(DLIBCRYPTO)
@@ -354,6 +352,3 @@ index bc4a920..58822f8 100644
# DO NOT DELETE THIS LINE -- make depend depends on it.
---
-2.2.2
-