aboutsummaryrefslogtreecommitdiffstats
path: root/main/parted/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/parted/APKBUILD')
-rw-r--r--main/parted/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/main/parted/APKBUILD b/main/parted/APKBUILD
new file mode 100644
index 0000000000..28cfc37210
--- /dev/null
+++ b/main/parted/APKBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=parted
+pkgver=2.4
+pkgrel=0
+pkgdesc="Utility to create, destroy, resize, check and copy partitions"
+url="http://www.gnu.org/software/parted/parted.html"
+arch="all"
+license="GPL3"
+subpackages="$pkgname-dev $pkgname-doc"
+depends=
+makedepends="pkgconfig e2fsprogs-dev readline-dev ncurses-dev lvm2-dev"
+source="ftp://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --disable-debug \
+ --disable-nls \
+ --disable-Werror
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+md5sums="76a6457ea88447d79d50ca331069b19c parted-2.4.tar.gz"