aboutsummaryrefslogtreecommitdiffstats
path: root/main/partimage
diff options
context:
space:
mode:
Diffstat (limited to 'main/partimage')
-rw-r--r--main/partimage/APKBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/main/partimage/APKBUILD b/main/partimage/APKBUILD
index e33141d454..83a01c341d 100644
--- a/main/partimage/APKBUILD
+++ b/main/partimage/APKBUILD
@@ -16,19 +16,15 @@ source="http://downloads.sourceforge.net/project/$pkgname/stable/$pkgver/$pkgnam
partimage-0.6.9-common.patch
"
-_builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir"/$pkgname-$pkgver
prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ default_prepare || return 1
+ update_config_guess || return 1
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export LIBS="$LIBS -lintl"
./configure --prefix=/usr \
--sysconfdir=/etc \
@@ -39,7 +35,7 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install
}