aboutsummaryrefslogtreecommitdiffstats
path: root/main/patch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/patch/APKBUILD')
-rw-r--r--main/patch/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/main/patch/APKBUILD b/main/patch/APKBUILD
new file mode 100644
index 0000000000..c51e3d1e5a
--- /dev/null
+++ b/main/patch/APKBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=patch
+pkgver=2.6.1
+pkgrel=2
+pkgdesc="Utility to apply diffs to files"
+url="http://www.gnu.org/software/patch/patch.html"
+arch="all"
+license='GPL'
+depends=
+source="ftp://ftp.gnu.org/gnu/patch/patch-2.6.tar.bz2"
+subpackages="$pkgname-doc"
+install="$pkgname.post-deinstall $pkgname.post-upgrade"
+
+_builddir="$srcdir"/$pkgname-2.6
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make prefix="$pkgdir"/usr mandir="$pkgdir"/usr/share/man install
+}
+
+md5sums="5729b1430ba6c2216e0f3eb18f213c81 patch-2.6.tar.bz2"