aboutsummaryrefslogtreecommitdiffstats
path: root/main/patchwork/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/patchwork/APKBUILD')
-rw-r--r--main/patchwork/APKBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/main/patchwork/APKBUILD b/main/patchwork/APKBUILD
index 7243ed9638..5f1fde1d43 100644
--- a/main/patchwork/APKBUILD
+++ b/main/patchwork/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=patchwork
pkgver=1.1.1
-pkgrel=0
+pkgrel=1
pkgdesc="Web-based patch tracking system "
url="http://jk.ozlabs.org/projects/patchwork/"
arch="noarch"
@@ -17,7 +17,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/getpatchwork/$pkgname/archiv
0001-support-busybox-readlink.patch
0002-remove-uneeded-bashism-from-tools-and-change-path.patch
nginx-uwsgi-patchwork-conf.ini
- uwsgi.patchwork.confd"
+ nginx-patchwork.conf"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -59,12 +59,13 @@ apache2_wsgi() {
nginx_wsgi() {
pkgdesc="$pkgname nginx wsgi support"
depends="nginx uwsgi-python"
- install -Dm644 "$pkgdir"/usr/share/webapps/patchwork/lib/nginx/patchwork.conf \
+ install_if="nginx patchwork uwsgi"
+ install -Dm644 "$srcdir"/nginx-patchwork.conf \
"$subpkgdir"/etc/nginx/conf.d/patchwork.conf || return 1
install -Dm644 "$srcdir"/nginx-uwsgi-patchwork-conf.ini \
"$subpkgdir"/etc/patchwork/patchwork.ini || return 1
- install -Dm644 "$srcdir"/uwsgi.patchwork.confd \
- "$subpkgdir"/etc/conf.d/uwsgi.patchwork || return 1
+ mkdir -p "$subpkgdir"/etc/uwsgi/conf.d
+ ln -sf /etc/patchwork/patchwork.ini "$subpkgdir"/etc/uwsgi/conf.d/patchwork.ini
}
mysql() {
@@ -89,15 +90,15 @@ pwclient() {
md5sums="9d665f68edc1afc6883873bb89dafe48 patchwork-1.1.1.tar.gz
c0bf2a78294773e6a5dc5fb5c9b525cf 0001-support-busybox-readlink.patch
2dde450ee27a24ea4b0448b1331e7cc9 0002-remove-uneeded-bashism-from-tools-and-change-path.patch
-698b5d0dedc03e76b6f9a33738c44e79 nginx-uwsgi-patchwork-conf.ini
-e3b6d46baf11e59a6547c8c0ff11935e uwsgi.patchwork.confd"
+f8807b30cceec56ec8428803a957537a nginx-uwsgi-patchwork-conf.ini
+1ada6412b1e22c084a08563bf75637d0 nginx-patchwork.conf"
sha256sums="e5bb8c453b2d042d13f87b51cba10360bd1d84ff181d6f2ee011c3b600c613f0 patchwork-1.1.1.tar.gz
43159a12dbbd4161ae1476c38b5435517dbc7260a1e25aa6263038cc4c267b99 0001-support-busybox-readlink.patch
499fc47ac715901fe0a5f5043f7ee722ab39e694451c70982830e1c728ea136d 0002-remove-uneeded-bashism-from-tools-and-change-path.patch
-51c1f9c32aff324b685b2d34200f528953d9f0e774eefd69d3b7788c1b16b3d8 nginx-uwsgi-patchwork-conf.ini
-e9054b0b7510f40e240619d6edf58200d3a759f3d87cbf78bcf4a5177ece1569 uwsgi.patchwork.confd"
+d1d952c2c22d5d11256d17745fb9845d73ebef290982c671b48d1344b32431f6 nginx-uwsgi-patchwork-conf.ini
+1d869db2b0e11c8f0e57bc4e69ac6939cfaad759850ce072c6e349b2803633cc nginx-patchwork.conf"
sha512sums="2f2f9114a2185ca34d493a87d34f16cfb4bc05f4c6c261f533faa9cbaded7b77a37f202715668bb428462848733ff042a130271addb28f89445ad22e212376d7 patchwork-1.1.1.tar.gz
a5d4e24741b66092a39c1ef4fdc76dffa1ddf87a69544ab0c374fb0701b0f7340a62ead86835d9bb412df5713f3ea3c0218e9e2e0cd01d9a1aad9414a3cc75fa 0001-support-busybox-readlink.patch
12d1b184c6cb1d3f2c51adab6b60638e4869e055e677897bb66ee1a52312e77817bec543842324e2cbc2c226f3ab9d11c3782b5ef3a6f5f5712996cadbc6c9c9 0002-remove-uneeded-bashism-from-tools-and-change-path.patch
-6bafda9fbd067b8f54fbff13cb28afe99ee1f26bb1b6f212264a8c9f3eb2723394b9c9ccea2fe97677505f32b324462f1646ac1990f1cce41cfbbbd19de9f701 nginx-uwsgi-patchwork-conf.ini
-a06c6176e44f5e2c04eb8609e3b8595ea59782e6f6167dcbb50a0af3163e484096c876bcb0cd67b18cb826eef4665f368aa8d9e5ccd32eab9bd5ca2ca8e2d080 uwsgi.patchwork.confd"
+28911a25e00a254237f7214fb681e5e984a2eae331e610be62967d5e246958e0f8d3f84861d8fd17c1190c1df72a25f28ddb33843b3679a3864beb00cb4b4961 nginx-uwsgi-patchwork-conf.ini
+862dd2522236a0b18d2a8d06f1ad91ad0fd0936fa502d95e09556641e67d42e1212821bfd7fb98923e4fe8b8a7369ded8c23831fb496b1e2833d9831c1b23725 nginx-patchwork.conf"