aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-astro-suntime/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-astro-suntime/APKBUILD')
-rw-r--r--main/perl-astro-suntime/APKBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/main/perl-astro-suntime/APKBUILD b/main/perl-astro-suntime/APKBUILD
index 07b2f4d372..d8069a78f0 100644
--- a/main/perl-astro-suntime/APKBUILD
+++ b/main/perl-astro-suntime/APKBUILD
@@ -3,31 +3,30 @@
pkgname=perl-astro-suntime
_realname=Astro-SunTime
pkgver=0.06
-pkgrel=0
+pkgrel=1
pkgdesc="Provides a function interface to calculate sun rise/set times."
-url="http://search.cpan.org/dist/Astro-SunTime/"
+url="https://metacpan.org/release/Astro-SunTime"
arch="noarch"
-license="GPL PerlArtistic"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
depends="perl"
makedepends="perl-dev perl-time-modules"
-install=
-subpackages=""
-source="http://search.cpan.org/CPAN/authors/id/R/RO/ROBF/$_realname-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/R/RO/ROBF/Astro-SunTime-$pkgver.tar.gz"
-_builddir="$srcdir/$_realname-$pkgver"
+builddir="$srcdir/$_realname-$pkgver"
build() {
- cd $_builddir
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make && make test || return 1
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ make test
}
package() {
- cd $_builddir
make DESTDIR="$pkgdir" install
# creates file collision among perl modules
find "$pkgdir" -name perllocal.pod -delete
-
}
sha512sums="58efedf8aa401ac9d4dbd526e19d67429b9740588e8706f7d5320c35b20e98014c5978ef9d76eacbfa551f5c323a74ad106331748a6ad77c537c0750da8ae65e Astro-SunTime-0.06.tar.gz"