aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-io-tty
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-io-tty')
-rw-r--r--main/perl-io-tty/APKBUILD31
1 files changed, 17 insertions, 14 deletions
diff --git a/main/perl-io-tty/APKBUILD b/main/perl-io-tty/APKBUILD
index 594181f34c..dc5b12a94c 100644
--- a/main/perl-io-tty/APKBUILD
+++ b/main/perl-io-tty/APKBUILD
@@ -4,33 +4,36 @@
pkgname=perl-io-tty
_pkgreal=IO-Tty
pkgver=1.12
-pkgrel=5
+pkgrel=6
pkgdesc="Pseudo ttys and constants"
-url="http://search.cpan.org/dist/IO-Tty/"
+url="https://metacpan.org/pod/IO::Tty"
arch="all"
-license="GPL PerlArtistic"
-cpandepends=""
-cpanmakedepends=""
-depends="$cpandepends perl"
-makedepends="perl-dev $cpanmakedepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/T/TO/TODDR/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/T/TO/TODDR/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
make
}
+check() {
+ cd "$builddir"
+ make test
+}
+
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}