aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-params-util
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-params-util')
-rw-r--r--main/perl-params-util/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/main/perl-params-util/APKBUILD b/main/perl-params-util/APKBUILD
new file mode 100644
index 0000000000..2accecfdba
--- /dev/null
+++ b/main/perl-params-util/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=perl-params-util
+pkgver=1.04
+pkgrel=0
+pkgdesc="Params::Util perl module"
+url="http://search.cpan.org/dist/Params-Util/"
+arch="all"
+license="GPLv2 or Artistic"
+depends="perl"
+makedepends="perl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/Params-Util-$pkgver.tar.gz"
+
+_builddir="$srcdir"/Params-Util-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ unset CFLAGS
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make test || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="84bfb0a16cff67f2077ece0e24408b0f Params-Util-1.04.tar.gz"