aboutsummaryrefslogtreecommitdiffstats
path: root/main/perl-text-template/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/perl-text-template/APKBUILD')
-rw-r--r--main/perl-text-template/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/main/perl-text-template/APKBUILD b/main/perl-text-template/APKBUILD
index d360154f82..172c12cd4e 100644
--- a/main/perl-text-template/APKBUILD
+++ b/main/perl-text-template/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-text-template
-pkgver=1.46
+pkgver=1.51
pkgrel=0
pkgdesc="Text::Template perl module"
url="http://search.cpan.org/dist/Text-Template"
@@ -9,9 +9,10 @@ arch="noarch"
license="GPL-1.0-or-later Artistic-1.0-Perl"
depends="perl"
makedepends="perl-dev"
+checkdepends="perl-test-warnings"
install=""
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/M/MJ/MJD/Text-Template-$pkgver.tar.gz"
+source="http://search.cpan.org/CPAN/authors/id/M/MS/MSCHOUT/Text-Template-$pkgver.tar.gz"
builddir="$srcdir/Text-Template-$pkgver"
build() {
@@ -20,10 +21,14 @@ build() {
make && make test
}
+check() {
+ make -C "$builddir" test
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="406c218d5d59dc74419749fb5151d011fb4d629e6de79378be1290db23a602a9f7897f04ac80080b8ec2661d997f9e05bed7861e480130750471166da0a94592 Text-Template-1.46.tar.gz"
+sha512sums="038a810746684b26cd6a763cfb8adff57a2ed8dc57e44b170b6ba6c8271d513289546294439cfe1c8b77f40153751596a023079ee79bfc6b59fa9393cfcc04f4 Text-Template-1.51.tar.gz"