aboutsummaryrefslogtreecommitdiffstats
path: root/main/pkgconf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/pkgconf/APKBUILD')
-rw-r--r--main/pkgconf/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/main/pkgconf/APKBUILD b/main/pkgconf/APKBUILD
index 63a3cc41cc..b6a29ebf28 100644
--- a/main/pkgconf/APKBUILD
+++ b/main/pkgconf/APKBUILD
@@ -32,9 +32,13 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
+ --build=${CBUILD} \
+ --host=${CHOST} \
|| return 1
make || return 1
- make check || return 1
+ if [ "$CHOST" = "$CBUILD" ]; then
+ make check || return 1
+ fi
}
package() {