aboutsummaryrefslogtreecommitdiffstats
path: root/main/pllua/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/pllua/APKBUILD')
-rw-r--r--main/pllua/APKBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/main/pllua/APKBUILD b/main/pllua/APKBUILD
index d354ac8bae..f658ec243d 100644
--- a/main/pllua/APKBUILD
+++ b/main/pllua/APKBUILD
@@ -2,13 +2,18 @@
# Maintainer: Michael Mason <ms13sp@gmail.com>
pkgname=pllua
pkgver=1.1.0
-pkgrel=0
+pkgrel=1
pkgdesc="Procedural language for PostgreSQL using Lua"
url="https://github.com/pllua/pllua"
-arch="all !s390x" # s390x: luajit is not avail
+arch="all"
license="GPL"
depends="postgresql"
-makedepends="postgresql-dev luajit-dev"
+# LuaJIT does not support s390x.
+case "$CARCH" in
+ s390x) _lua=lua5.3;;
+ *) _lua=luajit;;
+esac
+makedepends="postgresql-dev $_lua-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/pllua/$pkgname/archive/v$pkgver.tar.gz
fix-on-32bit.patch
fix-postgres10.patch"
@@ -17,8 +22,9 @@ options="!check" # tests require running PostgreSQL
build() {
cd "$builddir"
- make LUA_INCDIR=$(pkgconf --variable=includedir luajit) \
- LUALIB=$(pkgconf --libs luajit) \
+
+ make LUA_INCDIR=$(pkgconf --variable=includedir $_lua) \
+ LUALIB=$(pkgconf --libs $_lua) \
USE_PGXS=1
}