aboutsummaryrefslogtreecommitdiffstats
path: root/main/pngcrush/01-makefile-sanity.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/pngcrush/01-makefile-sanity.patch')
-rw-r--r--main/pngcrush/01-makefile-sanity.patch44
1 files changed, 39 insertions, 5 deletions
diff --git a/main/pngcrush/01-makefile-sanity.patch b/main/pngcrush/01-makefile-sanity.patch
index abbeff5533..58c2640e8c 100644
--- a/main/pngcrush/01-makefile-sanity.patch
+++ b/main/pngcrush/01-makefile-sanity.patch
@@ -1,13 +1,47 @@
---- pngcrush-1.7.25/Makefile
-+++ pngcrush-1.7.25/Makefile
-@@ -20,8 +20,8 @@
+--- pngcrush-1.7.27/Makefile.orig
++++ pngcrush-1.7.27/Makefile
+@@ -11,8 +11,8 @@
+ # macros --------------------------------------------------------------------
+
+ # uncomment these 2 lines only if you are using an external copy of zlib:
+-#ZINC = ../../zlib
+-#ZLIB = ../../zlib
++ZINC = ../../zlib
++ZLIB = ../../zlib
+
+ CC = gcc
+ LD = gcc
+@@ -20,10 +20,10 @@
#CFLAGS = -I. -O -Wall
#CFLAGS = -I. -O2
#CFLAGS = -I. -O3 -fomit-frame-pointer -Wall
-#CFLAGS = -I. -Os -fomit-frame-pointer -Wall
--CFLAGS = -I. -O3 -funroll-loops -fomit-frame-pointer -Wall -Wshadow
+CFLAGS = -I. -Os -fomit-frame-pointer -Wall
-+#CFLAGS = -I. -O3 -funroll-loops -fomit-frame-pointer -Wall -Wshadow
+ #CFLAGS = -I. -O3 -funroll-loops -fomit-frame-pointer -Wall -Wshadow
+ # Work around zlib compiler bug in 1.2.6
+-CFLAGS = -I. -O3 -funroll-loops -fomit-frame-pointer -Wall -Wshadow -DZ_SOLO
++#CFLAGS = -I. -O3 -funroll-loops -fomit-frame-pointer -Wall -Wshadow -DZ_SOLO
#CFLAGS = -I${ZINC} -I. -O3 -fomit-frame-pointer -Wall
# [note that -Wall is a gcc-specific compilation flag ("all warnings on")]
+@@ -37,15 +37,15 @@
+
+ PNGCRUSH = pngcrush
+
+-LIBS = -lm
++LIBS = -lz -lm
+ #LIBS = -L${ZLIB} -lz -lm
+ #LIBS = ${ZLIB}/libz.a -lm
+
+ # uncomment these 4 lines only if you are NOT using an external copy of zlib:
+-ZHDR = zlib.h
+-ZOBJS = adler32$(O) compress$(O) crc32$(O) deflate$(O) \
+- infback$(O) inffast$(O) inflate$(O) inftrees$(O) \
+- trees$(O) uncompr$(O) zutil$(O)
++#ZHDR = zlib.h
++#ZOBJS = adler32$(O) compress$(O) crc32$(O) deflate$(O) \
++# infback$(O) inffast$(O) inflate$(O) inftrees$(O) \
++# trees$(O) uncompr$(O) zutil$(O)
+
+ OBJS = pngcrush$(O) png$(O) pngerror$(O) pngget$(O) pngmem$(O) \
+ pngpread$(O) pngread$(O) pngrio$(O) pngrtran$(O) pngrutil$(O) \