aboutsummaryrefslogtreecommitdiffstats
path: root/main/postgresql-pllua/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/postgresql-pllua/APKBUILD')
-rw-r--r--main/postgresql-pllua/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/main/postgresql-pllua/APKBUILD b/main/postgresql-pllua/APKBUILD
index ca354695cf..454105a81a 100644
--- a/main/postgresql-pllua/APKBUILD
+++ b/main/postgresql-pllua/APKBUILD
@@ -13,8 +13,8 @@ license="MIT"
depends="postgresql"
# LuaJIT does not support s390x.
case "$CARCH" in
- s390x) _lua=lua5.3;;
- *) _lua=luajit; _luajit=luajit;;
+ s390x) _lua=lua5.3 _makeopts="LUAC=luac5.3 LUA=lua5.3";;
+ *) _lua=luajit; _makeopts="LUAJIT=luajit";;
esac
makedepends="postgresql-dev $_lua-dev"
options="!check" # tests require running PostgreSQL
@@ -27,7 +27,7 @@ builddir="$srcdir/$_pkgname-$_pkgver"
build() {
cd "$builddir"
- make ${_luajit:+"LUAJIT=$_luajit"} \
+ make $_makeopts \
LUA_INCDIR=$(pkgconf --variable=includedir $_lua) \
LUALIB=$(pkgconf --libs $_lua) \
USE_PGXS=1