aboutsummaryrefslogtreecommitdiffstats
path: root/main/putty/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/putty/APKBUILD')
-rw-r--r--main/putty/APKBUILD18
1 files changed, 14 insertions, 4 deletions
diff --git a/main/putty/APKBUILD b/main/putty/APKBUILD
index 5a38b39670..2f2edf5055 100644
--- a/main/putty/APKBUILD
+++ b/main/putty/APKBUILD
@@ -1,15 +1,24 @@
# Maintainer: Jeff Bilyk <jbilyk@alpinelinux.org>
pkgname=putty
-pkgver=0.69
+pkgver=0.71
pkgrel=0
pkgdesc="SSH and telnet client"
url="http://www.chiark.greenend.org.uk/~sgtatham/putty/"
arch="all"
-license="custom"
+license="MIT"
subpackages="$pkgname-doc"
-source="http://the.earth.li/~sgtatham/putty/latest/putty-$pkgver.tar.gz"
+source="http://the.earth.li/~sgtatham/putty/$pkgver/putty-$pkgver.tar.gz
+ fix-ppc64le-disable-werror.patch"
+options="!check" # no test suite
builddir="$srcdir"/putty-$pkgver
+# secfixes:
+# 0.71-r0:
+# - CVE-2019-9894
+# - CVE-2019-9895
+# - CVE-2019-9897
+# - CVE-2019-9898
+
build() {
cd "$builddir"
./configure \
@@ -25,4 +34,5 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-sha512sums="2739829adec60df5658709d61f8539d431f6b5d71b9b893fcefb2a04ac52bf2ace26f9ca784156d6540fa3f3e5858a86eb2921002b4cc05f9fbf22da7931ec2a putty-0.69.tar.gz"
+sha512sums="f8791210bd5925b26d51b13f0558eea15dbac40808051165b236d6436226f5c2b0aa7d69288ed9e2bddc1066455678cfd0af73ef6b715a136c42f3b6f754ac07 putty-0.71.tar.gz
+b10b2332ca0592db5664311d1bba7549ded79f16f6eef13dab3caca21626d97657f31e8603766e00b1a06f42cf229107eb53929730fe48e97cfc9216093fcc4c fix-ppc64le-disable-werror.patch"