aboutsummaryrefslogtreecommitdiffstats
path: root/main/putty
diff options
context:
space:
mode:
Diffstat (limited to 'main/putty')
-rw-r--r--main/putty/APKBUILD18
-rw-r--r--main/putty/fix-ppc64le-disable-werror.patch13
2 files changed, 27 insertions, 4 deletions
diff --git a/main/putty/APKBUILD b/main/putty/APKBUILD
index e722072b9c..4fc1019b93 100644
--- a/main/putty/APKBUILD
+++ b/main/putty/APKBUILD
@@ -1,15 +1,24 @@
# Maintainer: Jeff Bilyk <jbilyk@alpinelinux.org>
pkgname=putty
-pkgver=0.70
+pkgver=0.71
pkgrel=0
pkgdesc="SSH and telnet client"
url="https://www.chiark.greenend.org.uk/~sgtatham/putty/"
arch="all"
-license="custom"
+license="MIT"
subpackages="$pkgname-doc"
-source="http://the.earth.li/~sgtatham/putty/$pkgver/putty-$pkgver.tar.gz"
+source="http://the.earth.li/~sgtatham/putty/$pkgver/putty-$pkgver.tar.gz
+ fix-ppc64le-disable-werror.patch"
+options="!check" # no test suite
builddir="$srcdir"/putty-$pkgver
+# secfixes:
+# 0.71-r0:
+# - CVE-2019-9894
+# - CVE-2019-9895
+# - CVE-2019-9897
+# - CVE-2019-9898
+
build() {
cd "$builddir"
./configure \
@@ -24,4 +33,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="2aaf4fa2b4ad2d82eb5cdc4419ade79e0c5d8bd3c093db92b3c048e6107f85a5f1647f9d8203cda0906ce2b926725a75319f981cb32e6f1ebf50b1f738564fed putty-0.70.tar.gz"
+sha512sums="f8791210bd5925b26d51b13f0558eea15dbac40808051165b236d6436226f5c2b0aa7d69288ed9e2bddc1066455678cfd0af73ef6b715a136c42f3b6f754ac07 putty-0.71.tar.gz
+b10b2332ca0592db5664311d1bba7549ded79f16f6eef13dab3caca21626d97657f31e8603766e00b1a06f42cf229107eb53929730fe48e97cfc9216093fcc4c fix-ppc64le-disable-werror.patch"
diff --git a/main/putty/fix-ppc64le-disable-werror.patch b/main/putty/fix-ppc64le-disable-werror.patch
new file mode 100644
index 0000000000..2dba28bdb7
--- /dev/null
+++ b/main/putty/fix-ppc64le-disable-werror.patch
@@ -0,0 +1,13 @@
+diff --git a/configure b/configure
+index d68c382..5db360e 100755
+--- a/configure
++++ b/configure
+@@ -5995,7 +5995,7 @@ fi
+
+ if test "x$GCC" = "xyes"; then
+ :
+- WARNINGOPTS='-Wall -Werror -Wpointer-arith -Wvla'
++ WARNINGOPTS='-Wall -Wpointer-arith -Wvla'
+
+ else
+ :