aboutsummaryrefslogtreecommitdiffstats
path: root/main/py-gnome/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/py-gnome/APKBUILD')
-rw-r--r--main/py-gnome/APKBUILD6
1 files changed, 1 insertions, 5 deletions
diff --git a/main/py-gnome/APKBUILD b/main/py-gnome/APKBUILD
index 941c1e0c0a..df2cb5a6ca 100644
--- a/main/py-gnome/APKBUILD
+++ b/main/py-gnome/APKBUILD
@@ -7,7 +7,7 @@ _basever=2.28
pkgrel=5
pkgdesc="Python interface to GNOME libraries"
url="http://pygtk.org"
-arch="noarch"
+arch="all"
license="LGPL"
depends="$pkgname-bonobo $pkgname-gconf $pkgname-libgnome $pkgname-gnomevfs"
depends_dev="gtk+2.0-dev libgnome-dev py-gobject-dev py-gtk-dev python2-dev"
@@ -45,7 +45,6 @@ package() {
bonobo() {
pkgdesc="Python bindings for interfacing with Bonobo"
- arch="noarch"
depends="py-gtk $pkgname-gnomecanvas"
cd "$_builddir"
make -C bonobo DESTDIR="$subpkgdir" install || return 1
@@ -53,7 +52,6 @@ bonobo() {
gconf() {
pkgdesc="Python bindings for interfacing with GConf"
- arch="all"
depends="gconf py-gtk"
cd "$_builddir"
make -C gconf DESTDIR="$subpkgdir" install || return 1
@@ -68,7 +66,6 @@ gconf() {
gnomevfs() {
pkgdesc="Python bindings for interacting with gnome-vfs"
- arch="all"
depends="gnome-vfs"
cd "$_builddir"
make -C gnomevfs DESTDIR="$subpkgdir" install || return 1
@@ -76,7 +73,6 @@ gnomevfs() {
libgnome() {
pkgdesc="Python bindings for libgnome"
- arch="all"
depends="py-gtk $pkgname-bonobo $pkgname-gnomecanvas $pkgname-gnomevfs"
cd "$_builddir"
make -C gnome DESTDIR="$subpkgdir" install || return 1