aboutsummaryrefslogtreecommitdiffstats
path: root/main/py-incremental
diff options
context:
space:
mode:
Diffstat (limited to 'main/py-incremental')
-rw-r--r--main/py-incremental/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/main/py-incremental/APKBUILD b/main/py-incremental/APKBUILD
new file mode 100644
index 0000000000..55bf53e934
--- /dev/null
+++ b/main/py-incremental/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: prspkt <prspkt@protonmail.com>
+# Maintainer: prspkt <prspkt@protonmail.com>
+pkgname=py-incremental
+_pkgname=incremental
+pkgver=17.5.0
+pkgrel=0
+pkgdesc="Library that versions your Python projects"
+url="https://github.com/twisted/incremental"
+arch="noarch"
+license="MIT"
+depends=""
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="91443205f7c92ec8f6502f38379c5ac2fe441435ff9490af01e5420d6bb05bb1c666dd612fc45204199a34afd533fd3de1390ca482bb554dfec7d3a22958a4bc incremental-17.5.0.tar.gz"