aboutsummaryrefslogtreecommitdiffstats
path: root/main/py-twisted
diff options
context:
space:
mode:
Diffstat (limited to 'main/py-twisted')
-rw-r--r--main/py-twisted/APKBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/main/py-twisted/APKBUILD b/main/py-twisted/APKBUILD
index d9de99cf36..a778522fa0 100644
--- a/main/py-twisted/APKBUILD
+++ b/main/py-twisted/APKBUILD
@@ -1,35 +1,36 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py-twisted
_pkgname=Twisted
-pkgver=15.1.0
+pkgver=15.4.0
pkgrel=0
pkgdesc="Asynchronous networking framework written in Python."
url="http://twistedmatrix.com/"
arch="all"
license="MIT"
depends="py-crypto py-zope-interface"
-makedepends="python-dev"
+makedepends="python-dev py-setuptools libtirpc-dev"
install=""
subpackages="$pkgname-doc"
source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.bz2"
_builddir="$srcdir"/"$_pkgname"-$pkgver
+
build() {
cd "$_builddir"
- python setup.py build || return 1
+ CFLAGS="$CFLAGS `pkgconf --cflags libtirpc`" python setup.py build || return 1
}
package() {
cd "$_builddir"
python setup.py install --prefix=/usr --root="$pkgdir" || return 1
install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
- _mans="manhole.1 pyhtmlizer.1 tap2deb.1 tap2rpm.1 tapconvert.1 trial.1 twistd.1"
+ _mans="manhole.1 pyhtmlizer.1 tap2deb.1 tap2rpm.1 trial.1 twistd.1"
for _man in $_mans; do
install -m644 -D "$_builddir"/doc/core/man/$_man \
"$pkgdir"/usr/share/man/man1/$_man || return 1
done
}
-md5sums="df65e3da0bee81140e7637156802a518 Twisted-15.1.0.tar.bz2"
-sha256sums="82025d24cee178a7328a0467240bb6b1e7c283a9d85f115a9872dfcbfe20732a Twisted-15.1.0.tar.bz2"
-sha512sums="f7a755c7957d85c688db1076409ed1dd61967cf399253961caf584ab5b923d830fe995870bf7da1c9cbd304d98f0dc0a97c91ba92dc41301f652b360e5c5820f Twisted-15.1.0.tar.bz2"
+md5sums="5337ffb6aeeff3790981a2cd56db9655 Twisted-15.4.0.tar.bz2"
+sha256sums="78862662fa9ae29654bc2b9d349c3f1d887e6b2ed978512c4442d53ea861f05c Twisted-15.4.0.tar.bz2"
+sha512sums="df9f7121972e10ba73bf8c317514e0e19e0e1082c1c0388a6c1cf126bfd5bbbd91c21a02768983082120b0e50f6f599ebd5ad48e1c4a9cf75bf6bd2b685806e3 Twisted-15.4.0.tar.bz2"