aboutsummaryrefslogtreecommitdiffstats
path: root/main/qemu/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/qemu/APKBUILD')
-rw-r--r--main/qemu/APKBUILD29
1 files changed, 20 insertions, 9 deletions
diff --git a/main/qemu/APKBUILD b/main/qemu/APKBUILD
index 27f90c1e12..cf1e4a77eb 100644
--- a/main/qemu/APKBUILD
+++ b/main/qemu/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=qemu
pkgver=2.10.1
-pkgrel=0
+pkgrel=1
pkgdesc="QEMU is a generic machine emulator and virtualizer"
url="http://qemu.org/"
arch="all"
@@ -39,10 +39,9 @@ makedepends="
xfsprogs-dev
zlib-dev
"
-depends=""
pkggroups="qemu"
install="$pkgname.pre-install $pkgname.post-install"
-options="suid !strip" # needed for qemu-bridge-helper
+options="suid !strip" # suid needed for qemu-bridge-helper
subpackages="$pkgname-doc $pkgname-lang $pkgname-guest-agent:guest"
_subsystems="
@@ -130,6 +129,10 @@ source="http://wiki.qemu-project.org/download/$pkgname-$pkgver.tar.bz2
ignore-signals-33-and-64-to-allow-golang-emulation.patch
0001-linux-user-fix-build-with-musl-on-ppc64le.patch
fix-sockios-header.patch
+ fix-test-crypto-tls-x509-helpers-dont-use-sha1.patch
+ fix-test-io-channel-tls-handshake-completion.patch
+ fix-test-io-channel-tls-temp-directory.patch
+ test-crypto-ivgen-skip-essiv.patch
$pkgname-guest-agent.confd
$pkgname-guest-agent.initd
80-kvm.rules
@@ -165,6 +168,9 @@ builddir="$srcdir/$pkgname-$pkgver"
# - CVE-2017-5898
# - CVE-2017-5931
+case "$CARCH" in
+ s390x) options="!check";; # tests allegedly hangs
+esac
prepare() {
default_prepare # apply patches
@@ -233,12 +239,6 @@ build() {
--enable-guest-agent \
--disable-gtk
-
-# tests fails on x86
-# http://lists.gnu.org/archive/html/qemu-devel/2012-11/msg01429.html
-# http://web.archiveorange.com/archive/v/21oVv8wOfpQGkyy8EK0N
-# make check
-
if [ -n "$_arch" ]; then
cd "$builddir"/build-gtk
_compile_system \
@@ -251,6 +251,13 @@ build() {
fi
}
+check() {
+ cd "$builddir"/build
+
+ # XXX: ESSIV crypto tests are disabled, see test-crypto-ivgen-skip-essiv.patch.
+ make check V=1
+}
+
package() {
cd "$builddir"/build-user
make DESTDIR="$pkgdir" install
@@ -342,6 +349,10 @@ b6ed02aaf95a9bb30a5f107d35371207967edca058f3ca11348b0b629ea7a9c4baa618db68a3df72
fd178f2913639a0c33199b3880cb17536961f2b3ff171c12b27f4be6bca032d6b88fd16302d09c692bb34883346babef5c44407a6804b20a39a465bb2bc85136 ignore-signals-33-and-64-to-allow-golang-emulation.patch
a750e5e3d768cd41f704ca376a0ee460b83c0337f00cef0e8bced342d55b37fb9075f0a9ff805533b97f1e4dd02bf76c96ec202643df501784e85b985cdaf24e 0001-linux-user-fix-build-with-musl-on-ppc64le.patch
f0f99dc4f7fb475e3fab0262c0bc2c0dd8f17d77fe096c295fa1fc3e911ce07e1592f49c6ead7489246fecdd3a3f39f89ce05704af7f3fd384ce4f626f3c4601 fix-sockios-header.patch
+f4c6f9b1b1b22eecddb63e801a7e6070766868a63cc441647dbd571c86f29ba74d0fbd67f6016c85873d01ce537eed558eca05b92872ac70b4e9e0f17123ba2a fix-test-crypto-tls-x509-helpers-dont-use-sha1.patch
+f405d985a359069a310b03a714e6223dbe85c94442b03ba35d7e1fe5da02c02c6ad1ce52d3705a6f9fccb79c2494085298d93b3cb159bacaa3b3bf3597c25202 fix-test-io-channel-tls-handshake-completion.patch
+2233b45389467b4386253e113c9b08ff0d6ad55f06361f4c6f9f49f2528895847e12c1a6e7f66efa356d49b384b61945d970325a0008e4a8715ef48b9d84b7fd fix-test-io-channel-tls-temp-directory.patch
+8b8db136f78bd26b5da171effa9e11016ec2bc3e2fc8107228b5543b47aa370978ed883794aa4f917f334e284a5b49e82070e1da2d31d49301195b6713a48eff test-crypto-ivgen-skip-essiv.patch
d90c034cae3f9097466854ed1a9f32ab4b02089fcdf7320e8f4da13b2b1ff65067233f48809911485e4431d7ec1a22448b934121bc9522a2dc489009e87e2b1f qemu-guest-agent.confd
1cd24c2444c5935a763c501af2b0da31635aad9cf62e55416d6477fcec153cddbe7de205d99616def11b085e0dd366ba22463d2270f831d884edbc307c7864a6 qemu-guest-agent.initd
9b7a89b20fcf737832cb7b4d5dc7d8301dd88169cbe5339eda69fbb51c2e537d8cb9ec7cf37600899e734209e63410d50d0821bce97e401421db39c294d97be2 80-kvm.rules