aboutsummaryrefslogtreecommitdiffstats
path: root/main/qemu/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/qemu/APKBUILD')
-rw-r--r--main/qemu/APKBUILD29
1 files changed, 25 insertions, 4 deletions
diff --git a/main/qemu/APKBUILD b/main/qemu/APKBUILD
index 6485b99680..99b60bf9cc 100644
--- a/main/qemu/APKBUILD
+++ b/main/qemu/APKBUILD
@@ -1,16 +1,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=qemu
pkgver=1.0
-pkgrel=1
+pkgrel=3
pkgdesc="QEMU is a generic machine emulator and virtualizer"
url="http://www.nongnu.org/qemu/"
arch="all"
license="GPL-2 LGPL-2"
makedepends="zlib-dev sdl-dev alsa-lib-dev gnutls-dev ncurses-dev glib-dev
- jpeg-dev libpng-dev vde2-dev spice-dev"
+ jpeg-dev libpng-dev vde2-dev spice-dev paxctl"
depends=
install="qemu.pre-install"
subpackages="
+$pkgname-alpha
$pkgname-arm
$pkgname-cris
$pkgname-i386
@@ -31,11 +32,14 @@ $pkgname-sh4eb
$pkgname-sparc
$pkgname-sparc64
$pkgname-x86_64
+$pkgname-xtensa
+$pkgname-xtensaeb
$pkgname-img
"
source="http://wiki.qemu.org/download/qemu-$pkgver.tar.gz
80-kvm.rules
configure-libm.patch
+ librt.patch
"
prepare() {
@@ -78,7 +82,8 @@ package() {
cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install || return 1
install -Dm644 "$srcdir"/80-kvm.rules \
- "$pkgdir"/lib/udev/rules.d/80-kvm.rules
+ "$pkgdir"/lib/udev/rules.d/80-kvm.rules || return 1
+ paxctl -c -m "$pkgdir"/usr/bin/qemu-system-* || return 1
}
_subsys() {
@@ -88,6 +93,7 @@ _subsys() {
mv "$pkgdir"/usr/bin/qemu-system-$1 "$subpkgdir"/usr/bin/
}
+alpha() { _subsys alpha; }
arm() { _subsys arm; }
cris() { _subsys cris; }
i386() { _subsys i386; }
@@ -108,6 +114,8 @@ sh4eb() { _subsys sh4eb; }
sparc() { _subsys sparc; }
sparc64() { _subsys sparc64; }
x86_64() { _subsys x86_64; }
+xtensa() { _subsys xtensa; }
+xtensaeb() { _subsys xtensaeb; }
img() {
pkgdesc="QEMU command line tool for manipulating disk images"
@@ -116,8 +124,21 @@ img() {
mv "$pkgdir"/usr/bin/qemu-img \
"$pkgdir"/usr/bin/qemu-io \
"$subpkgdir"/usr/bin/
+
+ # we exploit the fact that -img subpackage are craeted last
+ # and check that we done have new systems that belongs in
+ # subpackage
+ local _bins= _ret=0
+ for i in "$pkgdir"/usr/bin/qemu-system-*; do
+ if [ -r "$i" ]; then
+ error "Please create a subpackage for ${i##*/}"
+ _ret=1
+ fi
+ done
+ return $_err
}
md5sums="a64b36067a191451323b0d34ebb44954 qemu-1.0.tar.gz
66660f143235201249dc0648b39b86ee 80-kvm.rules
-a69fe6ff552b61606c5550cac4294abc configure-libm.patch"
+a69fe6ff552b61606c5550cac4294abc configure-libm.patch
+9f6c3143d61748eedc8cf8d0e53aee2c librt.patch"