aboutsummaryrefslogtreecommitdiffstats
path: root/main/remmina/underlinking.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/remmina/underlinking.patch')
-rw-r--r--main/remmina/underlinking.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/main/remmina/underlinking.patch b/main/remmina/underlinking.patch
new file mode 100644
index 0000000000..4cabfea11c
--- /dev/null
+++ b/main/remmina/underlinking.patch
@@ -0,0 +1,32 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 465e905..4f1052d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -92,6 +92,11 @@ if(GCRYPT_FOUND)
+ add_definitions(-DHAVE_LIBGCRYPT)
+ endif()
+
++find_required_package(X11)
++find_library(GIO_LIBRARY NAMES gio-2.0)
++find_library(GOBJECT_LIBRARY NAMES gobject-2.0)
++find_library(GMODULE_LIBRARY NAMES gmodule-2.0)
++find_library(GTHREAD_LIBRARY NAMES gthread-2.0)
+ find_required_package(GTK)
+ if(GTK_FOUND)
+ add_subdirectory(remmina)
+diff --git a/remmina/CMakeLists.txt b/remmina/CMakeLists.txt
+index 0fe7bbf..5368a26 100644
+--- a/remmina/CMakeLists.txt
++++ b/remmina/CMakeLists.txt
+@@ -91,7 +91,7 @@ set(REMMINA_SRCS
+ add_executable(remmina ${REMMINA_SRCS})
+
+ include_directories(${GTK_INCLUDE_DIRS})
+-target_link_libraries(remmina ${GTK_LIBRARIES})
++target_link_libraries(remmina ${GTK_LIBRARIES} ${X11_LIBRARIES} ${GIO_LIBRARY} ${GOBJECT_LIBRARY} ${GMODULE_LIBRARY} ${GTHREAD_LIBRARY} -lintl -lpthread)
+
+ find_suggested_package(LIBSSH)
+ if(LIBSSH_FOUND)
+--
+1.7.9
+