aboutsummaryrefslogtreecommitdiffstats
path: root/main/shorewall-shell
diff options
context:
space:
mode:
Diffstat (limited to 'main/shorewall-shell')
-rw-r--r--main/shorewall-shell/APKBUILD42
-rw-r--r--main/shorewall-shell/redirect-excludes.patch15
-rw-r--r--main/shorewall-shell/restore-default-route.patch13
-rw-r--r--main/shorewall-shell/shorewall-policyrouting.patch47
-rw-r--r--main/shorewall-shell/shorewall-shell-ipset.patch12
-rw-r--r--main/shorewall-shell/shorewall-shell-providers-gateway-none.patch49
-rw-r--r--main/shorewall-shell/shorewall-shell-rp_filter.patch17
7 files changed, 0 insertions, 195 deletions
diff --git a/main/shorewall-shell/APKBUILD b/main/shorewall-shell/APKBUILD
deleted file mode 100644
index 8e087b1f4e..0000000000
--- a/main/shorewall-shell/APKBUILD
+++ /dev/null
@@ -1,42 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=shorewall-shell
-_v=4.2.11
-pkgver=4.2.11
-pkgrel=6
-pkgdesc="Shoreline Firewall shell-based compiler."
-url="http://www.shorewall.net/"
-arch="noarch"
-license="GPL-2"
-depends="shorewall-common"
-#subpackages="$pkgname-doc"
-source="http://www.shorewall.net/pub/shorewall/${_v%.*}/shorewall-$_v/$pkgname-$pkgver.tar.bz2
- shorewall-policyrouting.patch
- shorewall-shell-ipset.patch
- shorewall-shell-providers-gateway-none.patch
- shorewall-shell-rp_filter.patch
- restore-default-route.patch
- redirect-excludes.patch
- "
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$srcdir"/$pkgname-$pkgver
- PREFIX="$pkgdir" ./install.sh || return 1
-}
-
-md5sums="518a7f389a6f606c109acb7dfbe18372 shorewall-shell-4.2.11.tar.bz2
-64c01bc4f57203fb877bb334994eac38 shorewall-policyrouting.patch
-79745ea284a08cb167b9a356ee0bff3b shorewall-shell-ipset.patch
-0c6106a8cbb95d21c0c878a6235a65ac shorewall-shell-providers-gateway-none.patch
-d5eadb6be45aa41f80669452baa853a6 shorewall-shell-rp_filter.patch
-c971270086d5de15327f498d1be64fcb restore-default-route.patch
-90e54cbb55213a2b3dcb6f57d20d1490 redirect-excludes.patch"
diff --git a/main/shorewall-shell/redirect-excludes.patch b/main/shorewall-shell/redirect-excludes.patch
deleted file mode 100644
index 9230576bdb..0000000000
--- a/main/shorewall-shell/redirect-excludes.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- ./lib.nat.orig
-+++ ./lib.nat
-@@ -683,10 +683,10 @@
- fi
- ;;
- !*)
-- if [ $(list_count $addr) -gt 1 ]; then
-+# if [ $(list_count $addr) -gt 1 ]; then
- excludedests="${addr#\!}"
- addr=
-- fi
-+# fi
- ;;
- esac
-
diff --git a/main/shorewall-shell/restore-default-route.patch b/main/shorewall-shell/restore-default-route.patch
deleted file mode 100644
index 8640589420..0000000000
--- a/main/shorewall-shell/restore-default-route.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./lib.providers.orig
-+++ ./lib.providers
-@@ -378,7 +378,9 @@
- #
- # Capture the default route(s) if we don't have it (them) already.
- #
--[ -f \${VARDIR}/default_route ] || ip route list | grep -E '^\s*(default |nexthop )' > \${VARDIR}/default_route
-+if [ "\$RESTORE_DEFAULT_ROUTE" != "No" ] && ! [ -f \${VARDIR}/default_route ]; then
-+ ip route list | grep -E '^\s*(default |nexthop )' > \${VARDIR}/default_route
-+fi
- #
- # Initialize the file that holds 'undo' commands
- #
diff --git a/main/shorewall-shell/shorewall-policyrouting.patch b/main/shorewall-shell/shorewall-policyrouting.patch
deleted file mode 100644
index 26399108e3..0000000000
--- a/main/shorewall-shell/shorewall-policyrouting.patch
+++ /dev/null
@@ -1,47 +0,0 @@
---- old/lib.providers
-+++ new/lib.providers
-@@ -141,7 +141,7 @@
- # Add Provider $table ($number)
- #
- __EOF__
-- save_command "if interface_is_usable $interface; then"
-+ save_command "if [ -n \"$interface\" ] && interface_is_usable \"$interface\"; then"
- save_indent1="$INDENT"
- INDENT="$INDENT "
-
-@@ -283,7 +283,14 @@
- INDENT="$save_indent1"
- save_command else
-
-- if [ -n "$optional" ]; then
-+ if [ "${interface:--}" = "-" -a "${duplicate:--}" = "-" -a "${gateway:--}" = "-" -a "${options:--}" = "-" -a "${copy:--}" = "-" ]; then
-+ indent >&3 << __EOF__
-+
-+progress_message " Provider $table ($number) Added"
-+
-+__EOF__
-+
-+ elif [ -n "$optional" ]; then
- save_command " error_message \"WARNING: Interface $interface is not configured -- Provider $table ($number) not Added\""
- save_command " ${iface}_up="
- else
-@@ -316,10 +323,6 @@
- [ "x$source" = x- ] && source=
- [ "x$dest" = x- ] && dest= || dest="to $dest"
-
-- [ -n "${source}${dest}" ] || fatal_error "You must specify either the source or destination in an rt rule: \"$rule\""
--
-- [ -n "${dest:=to 0.0.0.0/0}" ]
--
- if [ -n "$source" ]; then
- case $source in
- *:*)
-@@ -332,8 +335,6 @@
- source="iif $source"
- ;;
- esac
-- else
-- source='from 0.0.0.0/0'
- fi
-
- case "$priority" in
diff --git a/main/shorewall-shell/shorewall-shell-ipset.patch b/main/shorewall-shell/shorewall-shell-ipset.patch
deleted file mode 100644
index 247eb83d35..0000000000
--- a/main/shorewall-shell/shorewall-shell-ipset.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./compiler
-+++ ./compiler
-@@ -5627,8 +5627,6 @@
-
- if [ -f \$f ]; then
- progress_message2 "Restoring IPSETS..."
-- ipset -U :all: :all:
-- ipset -U :all: :default:
- ipset -F
- ipset -X
- ipset -R < \$f
-
diff --git a/main/shorewall-shell/shorewall-shell-providers-gateway-none.patch b/main/shorewall-shell/shorewall-shell-providers-gateway-none.patch
deleted file mode 100644
index 53459ab5f5..0000000000
--- a/main/shorewall-shell/shorewall-shell-providers-gateway-none.patch
+++ /dev/null
@@ -1,49 +0,0 @@
---- /usr/share/shorewall-shell/lib.providers
-+++ ./lib.providers
-@@ -149,11 +149,13 @@
-
- save_command "${iface}_up=Yes"
-
-- save_command "qt ip route flush table $number"
-+ if [ "x$gateway" != "xnone" ]; then
-+ save_command "qt ip route flush table $number"
-
-- indent >&3 << __EOF__
-+ indent >&3 << __EOF__
- echo "qt ip route flush table $number" >> \${VARDIR}/undo_routing
- __EOF__
-+ fi
-
- if [ "x${duplicate:=-}" != x- ]; then
- if [ "x${copy:=-}" != "x-" ]; then
-@@ -183,6 +185,8 @@
- fi
-
- __EOF__
-+ elif [ "x$gateway" = "xnone" ]; then
-+ gateway=
- elif [ "x$gateway" != "x-" -a -n "$gateway" ]; then
- indent >&3 << __EOF__
- run_ip route replace $gateway src \$(find_first_interface_address $interface) dev $interface table $number
---- ./lib.providers.orig
-+++ ./lib.providers
-@@ -408,7 +408,7 @@
- save_command "#"
- save_command "# We don't have any 'balance' providers so we retore any default route that we've saved"
- save_command "#"
-- save_command restore_default_route
-+# save_command restore_default_route
- fi
-
- save_command "if [ -w /etc/iproute2/rt_tables ]; then"
---- ./lib.providers.orig
-+++ ./lib.providers
-@@ -267,7 +267,7 @@
- rulenum=\$((\$rulenum + 1))
- done
- __EOF__
-- elif [ -n "$DELETE_THEN_ADD" ]; then
-+ elif [ -n "$DELETE_THEN_ADD" ] && [ -n "$gateway" ]; then
- indent >&3 << __EOF__
-
- find_interface_addresses $interface | while read address; do
diff --git a/main/shorewall-shell/shorewall-shell-rp_filter.patch b/main/shorewall-shell/shorewall-shell-rp_filter.patch
deleted file mode 100644
index 0e3174c92c..0000000000
--- a/main/shorewall-shell/shorewall-shell-rp_filter.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- ./compiler.orig
-+++ ./compiler
-@@ -3991,12 +3991,12 @@
- __EOF__
- done
-
-- save_command "echo 1 > /proc/sys/net/ipv4/conf/all/rp_filter"
--
- if [ "$ROUTE_FILTER" = yes ]; then
- save_command "echo 1 > /proc/sys/net/ipv4/conf/default/rp_filter"
-+ save_command "echo 1 > /proc/sys/net/ipv4/conf/all/rp_filter"
- elif [ "$ROUTE_FILTER" = no ]; then
- save_command "echo 0 > /proc/sys/net/ipv4/conf/default/rp_filter"
-+ save_command "echo 0 > /proc/sys/net/ipv4/conf/all/rp_filter"
- fi
-
- save_command "[ -n \"\$NOROUTES\" ] || ip route flush cache"