aboutsummaryrefslogtreecommitdiffstats
path: root/main/snort/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/snort/APKBUILD')
-rw-r--r--main/snort/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/main/snort/APKBUILD b/main/snort/APKBUILD
index 37dc20244a..6517c1ecc0 100644
--- a/main/snort/APKBUILD
+++ b/main/snort/APKBUILD
@@ -3,14 +3,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=snort
pkgver=2.9.5.6
-pkgrel=0
+pkgrel=1
pkgdesc="An open source network intrusion prevention and detection system"
url="http://www.snort.org/"
arch="all"
license="GPL"
depends=
makedepends="pcre-dev libpcap-dev libnet-dev libdnet-dev daq-dev
- autoconf automake libtool bison flex zlib-dev"
+ autoconf automake libtool bison flex zlib-dev libtirpc-dev"
install="$pkgname.pre-install"
subpackages="$pkgname-doc $pkgname-dev"
source="http://www.snort.org/dl/snort-current/snort-$pkgver.tar.gz
@@ -45,6 +45,8 @@ prepare() {
build() {
cd "$_builddir"
+ export CFLAGS="$CFLAGS `pkgconf --cflags libtirpc`"
+ export LDFLAGS="$LDFLAGS `pkgconf --libs libtirpc`"
./configure \
--build=$CBUILD \
--host=$CHOST \