aboutsummaryrefslogtreecommitdiffstats
path: root/main/snort
diff options
context:
space:
mode:
Diffstat (limited to 'main/snort')
-rw-r--r--main/snort/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/main/snort/APKBUILD b/main/snort/APKBUILD
index 2e59cd3f9e..f1df701741 100644
--- a/main/snort/APKBUILD
+++ b/main/snort/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=snort
pkgver=2.9.3
-pkgrel=1
+pkgrel=2
pkgdesc="An open source network intrusion prevention and detection system"
url="http://www.snort.org/"
arch="all"
@@ -25,6 +25,8 @@ build() {
# fix parallel builds
sed -i -e 's/^all-local:.*/all-local: $(LTLIBRARIES)/' \
src/dynamic-preprocessors/*/Makefile.am || return 1
+ # correct paths in default config file
+ sed -i -e 's|/usr/local|/usr|' etc/snort.conf || return 1
aclocal -I m4 && autoconf && automake --add-missing && libtoolize || return 1
./configure --prefix=/usr \
@@ -45,6 +47,7 @@ package() {
install -D -m 755 ../snort.initd "$pkgdir"/etc/init.d/snort
install -D -m 644 ../snort.confd "$pkgdir"/etc/conf.d/snort
install -D -m 644 etc/snort.conf "$pkgdir"/etc/snort/snort.conf
+ mkdir -p "$pkgdir"/usr/lib/snort_dynamicrules
}
md5sums="e128f5d5d14dad335dc0c549c7fe2e98 snort-2.9.3.tar.gz