aboutsummaryrefslogtreecommitdiffstats
path: root/main/soundtouch
diff options
context:
space:
mode:
Diffstat (limited to 'main/soundtouch')
-rw-r--r--main/soundtouch/APKBUILD61
-rw-r--r--main/soundtouch/soundtouch-1.4.0-mmx-sse-compile-fix.patch14
-rw-r--r--main/soundtouch/soundtouch-1.4.0-x86_64-asm-broken.patch12
3 files changed, 87 insertions, 0 deletions
diff --git a/main/soundtouch/APKBUILD b/main/soundtouch/APKBUILD
new file mode 100644
index 0000000000..74a8c997a6
--- /dev/null
+++ b/main/soundtouch/APKBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=soundtouch
+pkgver=1.4.0
+pkgrel=0
+pkgdesc="Audio Processing library for changing Tempo, Pitch and Playback Rates"
+url="http://www.surina.net/soundtouch/"
+arch="all"
+license="LGPLv2+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://www.surina.net/soundtouch/soundtouch-$pkgver.tar.gz
+ soundtouch-1.4.0-mmx-sse-compile-fix.patch
+ soundtouch-1.4.0-x86_64-asm-broken.patch
+ "
+
+_builddir="$srcdir"/soundtouch
+prepare() {
+ local i
+ cd "$_builddir"
+ update_config_sub || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --enable-shared \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -rf "$pkgdir"/usr/doc
+}
+
+md5sums="fc4bb10401624899efe4fb554d4fd3ed soundtouch-1.4.0.tar.gz
+f0204136c90ce4f6d4761073151eb4dc soundtouch-1.4.0-mmx-sse-compile-fix.patch
+0d856bb5b519b18c6ba3a2e1770bdfd2 soundtouch-1.4.0-x86_64-asm-broken.patch"
+sha256sums="d7f40b1acf24789b3d24316e368859df2784135c29d244181020f94d803a11fb soundtouch-1.4.0.tar.gz
+8e693bfbe843e855f0bc9da200a76cac8679fac2f7ce5f26d76e3b12e874853c soundtouch-1.4.0-mmx-sse-compile-fix.patch
+6c084155f2648577892fc7fbeace06f5ea96b332136e5e98717fb22dc969aa7b soundtouch-1.4.0-x86_64-asm-broken.patch"
+sha512sums="6b2521861dd0dec7581c593c367f3569a7bc58b1fe5686b3ac2c52752b5e241f0affada3bacf12417f4567c1ee859e826171d75f772b289dd4058509596db30e soundtouch-1.4.0.tar.gz
+7bcb03b98d06decb091bab76e778b75a716e9a06fb498b4ca1daa40ac5884b44fd3c38c1c0bf45c365e8765a48826e2035f5b62af786bd91863c18d845396c8e soundtouch-1.4.0-mmx-sse-compile-fix.patch
+467d7186f9e4ed3433c3d9d8adf7f77b9d1ef1f60472b02991c3c83e80fc20f9a96e605a34035e3353d79c3c14d2000d756a1edb859d25cf3f4cd296d75eb3b0 soundtouch-1.4.0-x86_64-asm-broken.patch"
diff --git a/main/soundtouch/soundtouch-1.4.0-mmx-sse-compile-fix.patch b/main/soundtouch/soundtouch-1.4.0-mmx-sse-compile-fix.patch
new file mode 100644
index 0000000000..4369b178b3
--- /dev/null
+++ b/main/soundtouch/soundtouch-1.4.0-mmx-sse-compile-fix.patch
@@ -0,0 +1,14 @@
+diff -up soundtouch/source/SoundTouch/Makefile.in~ soundtouch/source/SoundTouch/Makefile.in
+--- soundtouch/source/SoundTouch/Makefile.in~ 2009-02-15 11:21:36.000000000 +0100
++++ soundtouch/source/SoundTouch/Makefile.in 2009-02-15 11:23:30.000000000 +0100
+@@ -209,7 +209,9 @@ libSoundTouch_la_SOURCES = AAFilter.cpp
+ # Note by authore: '-msse2' might not work in non-X86 compilations. If someone can
+ # fix this script to automatically check for CPU architecture, please submit a patch
+ # to me.
+-AM_CXXFLAGS = -O3 -msse2 -fcheck-new -I../../include
++AM_CXXFLAGS = -fcheck-new -I../../include
++mmx_optimized.lo : AM_CXXFLAGS = -mmmx -fcheck-new -I../../include
++sse_optimized.lo : AM_CXXFLAGS = -msse -fcheck-new -I../../include
+ all: all-am
+
+ .SUFFIXES:
diff --git a/main/soundtouch/soundtouch-1.4.0-x86_64-asm-broken.patch b/main/soundtouch/soundtouch-1.4.0-x86_64-asm-broken.patch
new file mode 100644
index 0000000000..4c777d60e6
--- /dev/null
+++ b/main/soundtouch/soundtouch-1.4.0-x86_64-asm-broken.patch
@@ -0,0 +1,12 @@
+diff -up soundtouch/include/STTypes.h~ soundtouch/include/STTypes.h
+--- soundtouch/include/STTypes.h~ 2009-01-25 17:32:53.000000000 +0100
++++ soundtouch/include/STTypes.h 2009-02-14 22:22:37.000000000 +0100
+@@ -87,7 +87,7 @@ namespace soundtouch
+
+ #endif
+
+- #if (WIN32 || __i386__ || __x86_64__)
++ #if (WIN32 || __i386__)
+ /// Define this to allow X86-specific assembler/intrinsic optimizations.
+ /// Notice that library contains also usual C++ versions of each of these
+ /// these routines, so if you're having difficulties getting the optimized