aboutsummaryrefslogtreecommitdiffstats
path: root/main/spice-gtk
diff options
context:
space:
mode:
Diffstat (limited to 'main/spice-gtk')
-rw-r--r--main/spice-gtk/APKBUILD6
-rw-r--r--main/spice-gtk/libressl.patch53
2 files changed, 2 insertions, 57 deletions
diff --git a/main/spice-gtk/APKBUILD b/main/spice-gtk/APKBUILD
index 11e6960758..3aef37f201 100644
--- a/main/spice-gtk/APKBUILD
+++ b/main/spice-gtk/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=spice-gtk
pkgver=0.34
-pkgrel=1
+pkgrel=2
pkgdesc="A GTK+ widget for SPICE clients"
url="http://spice-space.org/page/Spice-Gtk"
arch="all"
@@ -19,7 +19,6 @@ options="suid"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-tools
spice-glib:glib"
source="http://www.spice-space.org/download/gtk/$pkgname-$pkgver.tar.bz2
- libressl.patch
"
builddir="$srcdir"/$pkgname-$pkgver
@@ -57,5 +56,4 @@ glib() {
"$subpkgdir"/usr/lib/
}
-sha512sums="17ea737511855b47f5eaf5143756483542cf8ee83f8d276cbfb2c0407355f68ed329fcbed8a67737179f3e53587710634d6faa856590234ee68be7b4b13f2689 spice-gtk-0.34.tar.bz2
-3a5079767c29ee91d605faf2bbb3def052f285dc1e9999da16beb9b9e5307f580e5c6e5a01df6168eb2467ab9df32ea649a6a6cfd77a368f1868fcca84a097f5 libressl.patch"
+sha512sums="17ea737511855b47f5eaf5143756483542cf8ee83f8d276cbfb2c0407355f68ed329fcbed8a67737179f3e53587710634d6faa856590234ee68be7b4b13f2689 spice-gtk-0.34.tar.bz2"
diff --git a/main/spice-gtk/libressl.patch b/main/spice-gtk/libressl.patch
deleted file mode 100644
index be99f4b1fd..0000000000
--- a/main/spice-gtk/libressl.patch
+++ /dev/null
@@ -1,53 +0,0 @@
---- a/spice-common/common/ssl_verify.c
-+++ b/spice-common/common/ssl_verify.c
-@@ -33,12 +33,10 @@
- #include <string.h>
- #include <gio/gio.h>
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000
- static const unsigned char *ASN1_STRING_get0_data(const ASN1_STRING *asn1)
- {
- return M_ASN1_STRING_data(asn1);
- }
--#endif
-
- static int verify_pubkey(X509* cert, const char *key, size_t key_size)
- {
---- a/src/bio-gio.c
-+++ b/src/bio-gio.c
-@@ -23,7 +23,6 @@
- #include "spice-util.h"
- #include "bio-gio.h"
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000
- static BIO_METHOD one_static_bio;
-
- static int BIO_meth_set_read(BIO_METHOD *biom,
-@@ -89,8 +88,6 @@
- static void BIO_meth_free(BIO_METHOD *biom)
- {
- }
--
--#endif
-
- static long bio_gio_ctrl(G_GNUC_UNUSED BIO *b,
- int cmd,
---- a/src/spice-channel.c
-+++ b/src/spice-channel.c
-@@ -55,7 +55,6 @@
- static void spice_channel_send_migration_handshake(SpiceChannel *channel);
- static gboolean channel_connect(SpiceChannel *channel, gboolean tls);
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000
- static RSA *EVP_PKEY_get0_RSA(EVP_PKEY *pkey)
- {
- if (pkey->type != EVP_PKEY_RSA) {
-@@ -63,7 +62,7 @@
- }
- return pkey->pkey.rsa;
- }
--#endif
-+
- /**
- * SECTION:spice-channel
- * @short_description: the base channel class