aboutsummaryrefslogtreecommitdiffstats
path: root/main/texinfo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/texinfo/APKBUILD')
-rw-r--r--main/texinfo/APKBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/main/texinfo/APKBUILD b/main/texinfo/APKBUILD
index 1e5436c012..1f91127e25 100644
--- a/main/texinfo/APKBUILD
+++ b/main/texinfo/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=texinfo
-pkgver=4.13a
-pkgrel=3
+pkgver=5.0
+pkgrel=0
pkgdesc="Utilities to work with and produce manuals, ASCII text, and on-line documentation from a single source file"
url="http://www.gnu.org/software/texinfo/"
arch="all"
@@ -11,13 +11,20 @@ makedepends="ncurses-dev"
source="ftp://ftp.gnu.org/pub/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz"
subpackages="$pkgname-doc"
+_builddir="$srcdir"/texinfo-$pkgver
build() {
- cd ${srcdir}/${pkgname}-4.13
+ cd "$_builddir"
./configure --prefix=/usr || return 1
make || return 1
+}
+
+package() {
+ cd "$_builddir"
make DESTDIR=${pkgdir} install || return 1
rm -f ${pkgdir}/usr/share/info/dir
gzip ${pkgdir}/usr/share/info/*
}
-md5sums="71ba711519209b5fb583fed2b3d86fcb texinfo-4.13a.tar.gz"
+md5sums="918432285abe6fe96c98355594c5656a texinfo-5.0.tar.gz"
+sha256sums="2c579345a39a2a0bb4b8c28533f0b61356504a202da6a25d17d4d866af7f5803 texinfo-5.0.tar.gz"
+sha512sums="27822169cef9c8e727f8510ef234246f16f3ed7abfe268ade9b7fbc927dc78ed7dcc726850220a022c1537514d9bf934c514b7ca6663b63ad345f148fe83c6d4 texinfo-5.0.tar.gz"