aboutsummaryrefslogtreecommitdiffstats
path: root/main/unbound/swig.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/unbound/swig.patch')
-rw-r--r--main/unbound/swig.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/main/unbound/swig.patch b/main/unbound/swig.patch
new file mode 100644
index 0000000000..176e06c56d
--- /dev/null
+++ b/main/unbound/swig.patch
@@ -0,0 +1,11 @@
+--- ./Makefile.in.orig
++++ ./Makefile.in
+@@ -370,7 +370,7 @@
+ $(srcdir)/libunbound/unbound.h
+ libunbound/python/libunbound_wrap.c: $(srcdir)/libunbound/python/libunbound.i $(srcdir)/libunbound/unbound.h
+ @-if test ! -d libunbound/python; then $(INSTALL) -d libunbound/python; fi
+- $(SWIG) -python -o $@ $(CPPFLAGS) $(srcdir)/libunbound/python/libunbound.i
++ $(SWIG) -python -o $@ "$(CPPFLAGS)" $(srcdir)/libunbound/python/libunbound.i
+
+ # Pyunbound python unbound wrapper
+ _unbound.la: libunbound_wrap.lo libunbound.la