aboutsummaryrefslogtreecommitdiffstats
path: root/main/util-linux/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/util-linux/APKBUILD')
-rw-r--r--main/util-linux/APKBUILD18
1 files changed, 14 insertions, 4 deletions
diff --git a/main/util-linux/APKBUILD b/main/util-linux/APKBUILD
index a285feae89..4a375669d4 100644
--- a/main/util-linux/APKBUILD
+++ b/main/util-linux/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=util-linux
-pkgver=2.21.2
+pkgver=2.22.1
case $pkgver in
*.*.*) _v=${pkgver%.*};;
@@ -15,10 +15,12 @@ arch="all"
license="GPL-2 GPL Public Domain"
depends=
# use GNU sed til bb sed is fixed. Also GNU tar is needed
-makedepends="zlib-dev sed ncurses-dev tar"
+makedepends="zlib-dev sed ncurses-dev tar autoconf automake libtool"
install=
source="http://www.kernel.org/pub/linux/utils/util-linux/v${_v}/util-linux-$pkgver.tar.xz
program-invocation.patch
+ gentoo-no-scanf.patch
+ rpmatch.patch
"
subpackages="$pkgname-doc $pkgname-dev libuuid libblkid sfdisk cfdisk mcookie blkid"
replaces="e2fsprogs util-linux-ng"
@@ -32,6 +34,7 @@ prepare() {
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
+ autoreconf
}
build() {
@@ -40,6 +43,7 @@ build() {
# -e 's/strverscmp.h/dirent.h/g' \
# -i mount/lomount.c
+ # login utils are provided by shadow (with PAM) or busybox (no PAM) --nenolod
./configure --prefix=/usr \
--enable-raw \
--disable-uuidd \
@@ -47,6 +51,10 @@ build() {
--disable-tls \
--disable-kill \
--with-ncurses \
+ --disable-login \
+ --disable-last \
+ --disable-sulogin \
+ --disable-su \
|| return 1
make || return 1
}
@@ -107,5 +115,7 @@ mcookie() {
mv "$pkgdir"/usr/bin/mcookie "$subpkgdir"/usr/bin/
}
-md5sums="54ba880f1d66782c2287ee2c898520e9 util-linux-2.21.2.tar.xz
-9682a6ddd5abe65434a145ebe512c123 program-invocation.patch"
+md5sums="730cf9932531ed09b53a04ca30fcb4c9 util-linux-2.22.1.tar.xz
+9682a6ddd5abe65434a145ebe512c123 program-invocation.patch
+85125e2cc7d54dc2733bedc603886f81 gentoo-no-scanf.patch
+2e6d6835adc6e962249d1c11792649fa rpmatch.patch"