aboutsummaryrefslogtreecommitdiffstats
path: root/main/uwsgi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/uwsgi/APKBUILD')
-rw-r--r--main/uwsgi/APKBUILD15
1 files changed, 14 insertions, 1 deletions
diff --git a/main/uwsgi/APKBUILD b/main/uwsgi/APKBUILD
index 8f111aaad6..f12deab7c0 100644
--- a/main/uwsgi/APKBUILD
+++ b/main/uwsgi/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=uwsgi
pkgver=2.0.14
-pkgrel=8
+pkgrel=9
pkgdesc="uWSGI application container server"
url="http://projects.unbit.it/uwsgi/"
arch="all"
@@ -189,6 +189,19 @@ _plugin() {
depends="uwsgi"
cd "$builddir"
+
+ local requires=$(sed '$a print(" ".join(REQUIRES))' \
+ plugins/$name/uwsgiplugin.py 2>/dev/null | python3 2>/dev/null)
+
+ local req; for req in $requires; do
+ if echo "$_plugins" | grep -qw "$req"; then
+ depends="$depends $pkgname-$req"
+ else
+ error "There's no subpackage for requirement $req!"
+ return 1
+ fi
+ done
+
install -m 755 -D ${name}_plugin.so \
"$subpkgdir"/usr/lib/uwsgi/${name}_plugin.so || return 1
}