aboutsummaryrefslogtreecommitdiffstats
path: root/main/wget/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/wget/APKBUILD')
-rw-r--r--main/wget/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/main/wget/APKBUILD b/main/wget/APKBUILD
new file mode 100644
index 0000000000..4175d626a8
--- /dev/null
+++ b/main/wget/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
+pkgname=wget
+pkgver=1.12
+pkgrel=4
+pkgdesc="A network utility to retrieve files from the Web"
+url="http://www.gnu.org/software/wget/wget.html"
+arch="all"
+license="GPL3"
+depends=
+makedepends="openssl-dev"
+subpackages="$pkgname-doc"
+install="wget.post-deinstall"
+source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --disable-nls
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="141461b9c04e454dc8933c9d1f2abf83 wget-1.12.tar.gz"