aboutsummaryrefslogtreecommitdiffstats
path: root/main/wine/wine-1.5.30-missing-libwine.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/wine/wine-1.5.30-missing-libwine.patch')
-rw-r--r--main/wine/wine-1.5.30-missing-libwine.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/main/wine/wine-1.5.30-missing-libwine.patch b/main/wine/wine-1.5.30-missing-libwine.patch
new file mode 100644
index 0000000000..75fc83e6a5
--- /dev/null
+++ b/main/wine/wine-1.5.30-missing-libwine.patch
@@ -0,0 +1,45 @@
+commit ce4b6451aabbe83809c7483c748cfa009cc090d6
+Author: Alexandre Julliard <julliard@winehq.org>
+Date: Fri May 10 22:01:44 2013 +0200
+
+ configure: Add explicit install targets in libs/wine for make_makefiles.
+
+diff --git a/configure b/configure
+index d4c1f8e..ef38bfd 100755
+--- a/configure
++++ b/configure
+@@ -16379,7 +16379,7 @@ wine_fn_config_makefile documentation enable_documentation
+ wine_fn_config_makefile fonts enable_fonts install-lib
+ wine_fn_config_makefile include enable_include install-dev
+ wine_fn_config_makefile libs/port enable_libs_port
+-wine_fn_config_makefile libs/wine enable_libs_wine
++wine_fn_config_makefile libs/wine enable_libs_wine install-dev,install-lib
+ wine_fn_config_makefile libs/wpp enable_libs_wpp
+ wine_fn_config_makefile loader enable_loader install-lib,manpage
+ wine_fn_config_program aspnet_regiis enable_aspnet_regiis install
+diff --git a/configure.ac b/configure.ac
+index 6dd2348..b44673e 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -3173,7 +3173,7 @@ WINE_CONFIG_MAKEFILE([documentation])
+ WINE_CONFIG_MAKEFILE([fonts],,[install-lib])
+ WINE_CONFIG_MAKEFILE([include],,[install-dev])
+ WINE_CONFIG_MAKEFILE([libs/port])
+-WINE_CONFIG_MAKEFILE([libs/wine])
++WINE_CONFIG_MAKEFILE([libs/wine],,[install-dev,install-lib])
+ WINE_CONFIG_MAKEFILE([libs/wpp])
+ WINE_CONFIG_MAKEFILE([loader],,[install-lib,manpage])
+ WINE_CONFIG_PROGRAM(aspnet_regiis,,[install])
+diff --git a/libs/wine/Makefile.in b/libs/wine/Makefile.in
+index b8dc385..7de7799 100644
+--- a/libs/wine/Makefile.in
++++ b/libs/wine/Makefile.in
+@@ -111,4 +111,8 @@ version.c: dummy
+ $(RELPATH):
+ @cd $(TOOLSDIR)/tools && $(MAKE) relpath$(TOOLSEXT)
+
++# Make sure that make_makefiles sees the install rules
++install install-lib::
++install install-dev::
++
+ @LIBWINE_RULES@