aboutsummaryrefslogtreecommitdiffstats
path: root/main/wpa_supplicant/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/wpa_supplicant/APKBUILD')
-rw-r--r--main/wpa_supplicant/APKBUILD23
1 files changed, 17 insertions, 6 deletions
diff --git a/main/wpa_supplicant/APKBUILD b/main/wpa_supplicant/APKBUILD
index 43c8eefce3..4fb5a17afc 100644
--- a/main/wpa_supplicant/APKBUILD
+++ b/main/wpa_supplicant/APKBUILD
@@ -1,22 +1,30 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=wpa_supplicant
pkgver=1.0
-pkgrel=0
+pkgrel=1
pkgdesc="A utility providing key negotiation for WPA wireless networks"
url="http://hostap.epitest.fi/wpa_supplicant"
arch="all"
license="GPL"
subpackages="$pkgname-doc"
depends=
-makedepends="openssl-dev dbus-dev libnl-dev"
+makedepends="openssl-dev dbus-dev libnl3-dev"
source="http://hostap.epitest.fi/releases/$pkgname-$pkgver.tar.gz
wpa_supplicant.initd
wpa_supplicant.confd
+ libnl3-includes.patch
"
-_builddir="$srcdir"/$pkgname-$pkgver/$pkgname
+_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
+ for i in *.patch; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+
+ cd "$_builddir"/wpa_supplicant
# Toolchain setup
echo "CC = ${CC:-gcc}" > .config
@@ -87,17 +95,19 @@ prepare() {
# Enable mitigation against certain attacks against TKIP
echo "CONFIG_DELAYED_MIC_ERROR_REPORT=y" >> .config
+
+ echo "CONFIG_LIBNL32=y" >> .config
}
build() {
- cd "$_builddir"
+ cd "$_builddir"/wpa_supplicant
make LIBDIR=/lib BINDIR=/sbin || return 1
# comment out the network={ } stansas in config
sed -i -e '/^network=/,/}/s/^/#/' wpa_supplicant.conf
}
package() {
- cd "$_builddir"
+ cd "$_builddir"/wpa_supplicant
make DESTDIR="$pkgdir" LIBDIR=/lib BINDIR=/sbin install || return 1
install -Dm644 wpa_supplicant.conf \
"$pkgdir"/etc/wpa_supplicant/wpa_supplicant.conf
@@ -124,4 +134,5 @@ package() {
}
md5sums="8650f6aa23646ef634402552d0669640 wpa_supplicant-1.0.tar.gz
55f853354f51ba947e4dd6ee2bb0d64a wpa_supplicant.initd
-bc117427f2c538439f3f1481a028ee06 wpa_supplicant.confd"
+bc117427f2c538439f3f1481a028ee06 wpa_supplicant.confd
+473fb6b77909ec5a50b6f4d91370e86b libnl3-includes.patch"