aboutsummaryrefslogtreecommitdiffstats
path: root/main/x264
diff options
context:
space:
mode:
Diffstat (limited to 'main/x264')
-rw-r--r--main/x264/APKBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/main/x264/APKBUILD b/main/x264/APKBUILD
index 663404e560..c24cb67ff8 100644
--- a/main/x264/APKBUILD
+++ b/main/x264/APKBUILD
@@ -7,18 +7,17 @@ url="http://www.videolan.org/developers/x264.html"
arch="all"
license="GPL"
depends=
-makedepends="libx11-dev bash yasm"
+makedepends="libx11-dev bash yasm coreutils"
subpackages="$pkgname-dev"
source="ftp://ftp.videolan.org/pub/x264/snapshots/x264-snapshot-$pkgver-2245-stable.tar.bz2"
+
_builddir="$srcdir/$pkgname-snapshot-$pkgver-2245-stable"
build() {
cd "$_builddir"
local _asmopts=
- if [ "$CARCH" = "x86" ]; then
- _asmopts="--disable-asm"
- fi
+ [ "$CARCH" = "x86" ] && _asmopts="--disable-asm"
+ # note: not autotools
./configure \
- --build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--enable-visualize \