aboutsummaryrefslogtreecommitdiffstats
path: root/main/x265/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/x265/APKBUILD')
-rw-r--r--main/x265/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/main/x265/APKBUILD b/main/x265/APKBUILD
new file mode 100644
index 0000000000..d4a574c350
--- /dev/null
+++ b/main/x265/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=x265
+pkgver=1.7
+pkgrel=0
+pkgdesc="Open Source H265/HEVC video encoder"
+url="https://bitbucket.org/multicoreware/x265"
+arch="all"
+license="GPL"
+depends=""
+depends_dev=""
+makedepends="$depends_dev yasm cmake"
+install=""
+subpackages="$pkgname-dev"
+source="http://ftp.videolan.org/pub/videolan/x265/x265_${pkgver}.tar.gz
+ x265-1.7-fix-slowness-with-gcc-5.1.patch"
+
+_builddir="$srcdir/x265_$pkgver"
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"/build/linux
+ cmake -G "Unix Makefiles" -DCMAKE_INSTALL_PREFIX=/usr ../../source
+}
+
+package() {
+ cd "$_builddir"/build/linux
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="ff31a807ebc868aa59b60706e303102f x265_1.7.tar.gz
+30c7fc491f22cbdec1ee17caab7d620a x265-1.7-fix-slowness-with-gcc-5.1.patch"
+sha256sums="a52ca95e8e64219c1e8e73a9abf0bb7151ced2c93756a623cf2b7e5cf8226585 x265_1.7.tar.gz
+1414e10c96654070cf0e96dcb79c560fc415e48250cd5bd0ad8a2a6d7f754d50 x265-1.7-fix-slowness-with-gcc-5.1.patch"
+sha512sums="cf6fce24b008d36bbc79e2488ab5fb3010aa588113645597ffc66959088a73b3ba72f6bb81bd16e36847a73b50b8f264cff0899162552418ae499170c286eb89 x265_1.7.tar.gz
+5d0807ade416c15156252b27e9b6fca10743274ec3b1e8e638299604b3a12f437e54aa5864c179c9f2b976011d67a7ab648252ade01d7d7298d9c4097eba3c4d x265-1.7-fix-slowness-with-gcc-5.1.patch"