aboutsummaryrefslogtreecommitdiffstats
path: root/main/xcb-proto/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/xcb-proto/APKBUILD')
-rw-r--r--main/xcb-proto/APKBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/main/xcb-proto/APKBUILD b/main/xcb-proto/APKBUILD
index 9214a736e1..48f8e2a000 100644
--- a/main/xcb-proto/APKBUILD
+++ b/main/xcb-proto/APKBUILD
@@ -1,17 +1,22 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xcb-proto
pkgver=1.12
-pkgrel=0
+pkgrel=1
pkgdesc="XML-XCB protocol descriptions"
url="http://xcb.freedesktop.org/"
arch="noarch"
license="custom"
depends=
-makedepends="python2"
-source="http://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2"
+makedepends="python3"
+# no testsuite
+options="!check"
+source="http://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2
+ python3.patch"
+
+builddir="${srcdir}/${pkgname}-${pkgver}"
build() {
- cd "$srcdir"/${pkgname}-${pkgver}
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -21,11 +26,10 @@ build() {
}
package() {
- cd "$srcdir"/${pkgname}-${pkgver}
+ cd "$builddir"
make DESTDIR=${pkgdir} install || return 1
install -m755 -d ${pkgdir}/usr/share/licenses/${pkgname}
install -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/ || return 1
}
-md5sums="14e60919f859560f28426a685a555962 xcb-proto-1.12.tar.bz2"
-sha256sums="5922aba4c664ab7899a29d92ea91a87aa4c1fc7eb5ee550325c3216c480a4906 xcb-proto-1.12.tar.bz2"
-sha512sums="1f427eaf223971b25b56c9f641350e03f5ebeb17a1fc212ce2a0c892de7aba7e53d5e3958b073a122bb344c387c0ff394cf96f542ff046f33de4e1cd27fb9e5c xcb-proto-1.12.tar.bz2"
+sha512sums="1f427eaf223971b25b56c9f641350e03f5ebeb17a1fc212ce2a0c892de7aba7e53d5e3958b073a122bb344c387c0ff394cf96f542ff046f33de4e1cd27fb9e5c xcb-proto-1.12.tar.bz2
+291fb6410c656e3744ba51054cb51d25c10eb738223d65367b43dca7bfa8b82440e9c0836f615fcee64040e79087d68d25c2d329348623b936abb520a9135bfd python3.patch"