aboutsummaryrefslogtreecommitdiffstats
path: root/main/xen/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/xen/APKBUILD')
-rw-r--r--main/xen/APKBUILD92
1 files changed, 92 insertions, 0 deletions
diff --git a/main/xen/APKBUILD b/main/xen/APKBUILD
new file mode 100644
index 0000000000..4df5c517e2
--- /dev/null
+++ b/main/xen/APKBUILD
@@ -0,0 +1,92 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=xen
+pkgver=4.1.0
+pkgrel=1
+pkgdesc="Xen hypervisor"
+url="http://www.xen.org/"
+license="GPL"
+depends="coreutils python sed gawk"
+makedepends="libgcrypt-dev gnutls-dev pciutils-dev texinfo wget mesa-dev sdl-dev zlib-dev openssl-dev util-linux-ng-dev python-dev gettext-dev ncurses-dev perl"
+install=
+subpackages="$pkgname-doc"
+source="http://bits.xensource.com/oss-xen/release/$pkgver/$pkgname-$pkgver.tar.gz
+ xen-blktap-uclibc.patch
+ xen-blktap2-uclibc.patch
+ xen-disable-firmware.patch
+ xen-dont-use-lib64.patch
+ xen-sed-is-broken-hack.patch
+ blktap-write.patch
+ xend.initd
+ xendomains.initd"
+arch="x86_64"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+
+ msg "Patching sources..."
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i..."
+ patch -s -p1 -N -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+ msg "Sources have been patched successfully."
+
+ # remove all -Werror
+ msg "Eradicating -Werror..."
+ find -name '*.mk' -o -name 'Make*' | xargs sed -i -e 's/-Werror//g'
+}
+
+build() {
+ cd "$_builddir"
+
+ # We unset $CFLAGS and $LDFLAGS because Xen's buildsystem does not
+ # like these values being set. Arguably this is a bug but I can't be
+ # bothered to track it down. --nenolod
+ unset CFLAGS
+ unset LDFLAGS
+
+ # If we provide no parameters it tries to build a kernel image. We
+ # definitely don't want that.
+ msg "Running preflight check..."
+ (cd tools/check; ./chk build) || return 1
+
+ msg "Building hypervisor..."
+ make -j1 xen || return 1
+
+ msg "Building tools..."
+ make -j1 tools || return 1
+
+ msg "Building stub domains..."
+ make -j1 stubdom || return 1
+}
+
+package() {
+ cd "$_builddir"
+
+ # We unset $CFLAGS and $LDFLAGS because Xen's buildsystem does not
+ # like these values being set. Arguably this is a bug but I can't be
+ # bothered to track it down. --nenolod
+ unset CFLAGS
+ unset LDFLAGS
+
+ make DESTDIR="$pkgdir" install-xen install-tools install-stubdom
+
+ install -m755 -D "$srcdir"/xend.initd "$pkgdir"/etc/init.d/xend
+ install -m755 -D "$srcdir"/xendomains.initd "$pkgdir"/etc/init.d/xendomains
+}
+
+md5sums="db3e1542b7719f375593b2b32b01a177 xen-4.1.0.tar.gz
+edb5c3e7fba8214702fac709f0e53124 xen-blktap-uclibc.patch
+1f7f847ae0baa915c7b52d0ed5869fe6 xen-blktap2-uclibc.patch
+a569f16a7e3c832ba3fab6154f657244 xen-disable-firmware.patch
+20ce621f3a2fc8ae78e74b9b72da775c xen-dont-use-lib64.patch
+0cec6a97de9e4bc178f3e71190495cc3 xen-sed-is-broken-hack.patch
+56af00443c8d40944082e26304452a5e blktap-write.patch
+1d81b04f8c8b919879a73f0e3d2fe80f xend.initd
+a2b5234483f1b5892d22e9315d9c307f xendomains.initd"