aboutsummaryrefslogtreecommitdiffstats
path: root/main/xen/busybox-sed.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/xen/busybox-sed.patch')
-rw-r--r--main/xen/busybox-sed.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/main/xen/busybox-sed.patch b/main/xen/busybox-sed.patch
new file mode 100644
index 0000000000..e1a9531577
--- /dev/null
+++ b/main/xen/busybox-sed.patch
@@ -0,0 +1,11 @@
+--- ./xen/arch/x86/boot/Makefile.orig
++++ ./xen/arch/x86/boot/Makefile
+@@ -2,7 +2,7 @@
+
+ head.o: reloc.S
+
+-BOOT_TRAMPOLINE := $(shell sed -n 's,^\#define[[:space:]]\{1\,\}BOOT_TRAMPOLINE[[:space:]]\{1\,\},,p' $(BASEDIR)/include/asm-x86/config.h)
++BOOT_TRAMPOLINE := $(shell sed -n 's,^\#define[[:space:]]\+BOOT_TRAMPOLINE[[:space:]]\+,,p' $(BASEDIR)/include/asm-x86/config.h)
+ %.S: %.c
+ RELOC=$(BOOT_TRAMPOLINE) $(MAKE) -f build32.mk $@
+