aboutsummaryrefslogtreecommitdiffstats
path: root/main/xen/gcc5-cflags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/xen/gcc5-cflags.patch')
-rw-r--r--main/xen/gcc5-cflags.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/main/xen/gcc5-cflags.patch b/main/xen/gcc5-cflags.patch
new file mode 100644
index 0000000000..d8e0bcdac2
--- /dev/null
+++ b/main/xen/gcc5-cflags.patch
@@ -0,0 +1,21 @@
+gcc5 gives array-bounds warning on xen/common/symbols.c
+ also maybe-uninitialized warning on xen/xsm/flask/ss/policydb.c
+
+--- xen-4.5.0/xen/common/Makefile.orig 2015-01-12 16:53:24.000000000 +0000
++++ xen-4.5.0/xen/common/Makefile 2015-02-14 15:40:29.722759007 +0000
+@@ -72,3 +72,5 @@
+
+ subdir-y += libelf
+ subdir-$(HAS_DEVICE_TREE) += libfdt
++
++CFLAGS += -Wno-error=array-bounds
+--- xen-4.5.0/xen/xsm/flask/Makefile.orig 2015-01-12 16:53:24.000000000 +0000
++++ xen-4.5.0/xen/xsm/flask/Makefile 2015-02-14 16:49:54.376183206 +0000
+@@ -5,6 +5,7 @@
+ subdir-y += ss
+
+ CFLAGS += -I./include
++CFLAGS += -Wno-error=maybe-uninitialized
+
+ AWK = awk
+