aboutsummaryrefslogtreecommitdiffstats
path: root/main/xen/xen-disable-werror.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/xen/xen-disable-werror.patch')
-rw-r--r--main/xen/xen-disable-werror.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/main/xen/xen-disable-werror.patch b/main/xen/xen-disable-werror.patch
new file mode 100644
index 0000000000..c2c5512457
--- /dev/null
+++ b/main/xen/xen-disable-werror.patch
@@ -0,0 +1,33 @@
+--- xen-4.0.1/Config.mk
++++ xen-4.0.1.mod/Config.mk
+@@ -14,7 +14,7 @@
+
+ # Tools to run on system hosting the build
+ HOSTCC = gcc
+-HOSTCFLAGS = -Wall -Werror -Wstrict-prototypes -O2 -fomit-frame-pointer
++HOSTCFLAGS = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer
+ HOSTCFLAGS += -fno-strict-aliasing
+
+ DISTDIR ?= $(XEN_ROOT)/dist
+--- xen-4.0.1/extras/mini-os/minios.mk
++++ xen-4.0.1.mod/extras/mini-os/minios.mk
+@@ -6,7 +6,7 @@
+
+ # Define some default flags.
+ # NB. '-Wcast-qual' is nasty, so I omitted it.
+-DEF_CFLAGS += -fno-builtin -Wall -Werror -Wredundant-decls -Wno-format -Wno-redundant-decls
++DEF_CFLAGS += -fno-builtin -Wall -Wredundant-decls -Wno-format -Wno-redundant-decls
+ DEF_CFLAGS += $(call cc-option,$(CC),-fno-stack-protector,)
+ DEF_CFLAGS += $(call cc-option,$(CC),-fgnu89-inline)
+ DEF_CFLAGS += -Wstrict-prototypes -Wnested-externs -Wpointer-arith -Winline
+--- xen-4.0.1/tools/libxc/Makefile
++++ xen-4.0.1.mod/tools/libxc/Makefile
+@@ -57,7 +57,7 @@
+
+ -include $(XEN_TARGET_ARCH)/Makefile
+
+-CFLAGS += -Werror -Wmissing-prototypes
++CFLAGS += -Wmissing-prototypes
+ CFLAGS += $(INCLUDES) -I. -I../xenstore -I../include
+
+ # Needed for posix_fadvise64() in xc_linux.c